Location Bar not loading new sites in specific profile

RESOLVED INCOMPLETE

Status

()

Firefox
Bookmarks & History
RESOLVED INCOMPLETE
8 years ago
7 years ago

People

(Reporter: dschafer, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
(Reporter)

Comment 1

8 years ago
On my main profile in both Firefox 3.6 and the current Minefield, sites I visit or bookmark now don't seem to be showing up in the Location Bar autocomplete.  This does not occur in a new profile that I create from scratch.  I also can't delete that history entry from the Show All History dialog.

Steps to Reproduce:
1. Visit www.barackobama.com (A site I haven't visited before)
2. Do anything
3. Later, type barack into the location bar.  Nothing will auto-complete.
4. Go to History, try and delete entry for www.barackobama.com.  It will not delete.

Occurs on
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

Sorry for the accidental quick-file on the bug.
Summary: Awesomebar → Location Bar not loading new sites in specific profile
(Reporter)

Comment 2

8 years ago
Also occurs on
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a4pre) Gecko/20100405 Minefield/3.7a4pre

I also tried bookmarking www.barackobama.com, and even as a bookmark on my bookmarks bar, it doesn't show up as a location bar auto-complete.  None of this is www.barackobama.com specific, I'm simply using that as an example.
WFM in
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a4pre) Gecko/20100405 Minefield/3.7a4pre

Have you tried a fresh profile?  It sounds like maybe something in your profile is broken.
Is this on a networked filesystem?
(Reporter)

Comment 5

8 years ago
Fresh profile fixes the problem.

It's not on a networked file system, just the hard drive on my Mac Book Pro.

The computer this occurs on has been having major stability issues; a system crash might have corrupted something?
That's probably it.

If you feel like it, you might try swapping the places.sqlite files between the broken profile & the fresh profile -- I'd guess that's the file that's at fault here.

Without reliable steps-to-reproduce, though, I'm not sure if there's much we can do to figure out what caused the corruption or how to prevent it, though. :-/
(Reporter)

Comment 7

8 years ago
Okay, swapping places.sqlite causes the new profile to get messed up.  I looked into places.sqlite with /usr/bin/sqlite3, and didn't see anything terribly messed up at first glance.  In particular:
select * from moz_bookmarks;
yields the row:
2767|1|53920|3|7|Organizing for America | BarackObama.com|||1270248463503912|1270248463503912
So places.sqlite3 seems to have that bookmark data at least.

I've switched to the new profile, so this isn't affecting me at this point; I'll keep the old profile around, though.
Unless you can still mail me that old places.sqlite file after this much time, there is nothing in the bug allowing us to debug it. So I'm resolving.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.