Closed Bug 557299 Opened 11 years ago Closed 7 years ago

Remove declaration of bogus and nonexistent CERT_DestroyRDN function from public NSS header files

Categories

(NSS :: Libraries, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED
3.16.1

People

(Reporter: jdennis, Assigned: Cykesiopka)

Details

Attachments

(1 file)

999 bytes, patch
elio.maldonado.batiz
: review+
Details | Diff | Splinter Review
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100330 Fedora/3.5.9-1.fc12 Firefox/3.5.9
Build Identifier: 3.12.6

The function CERT_DestroyRDN is defined as an exported function in cert.h. However it is not implemented and hence not exported in the library.

Reproducible: Always

Steps to Reproduce:
1. call CERT_DestroyRDN()

Actual Results:  
undefined symbol: CERT_DestroyRDN


The work around appears to be calling PORT_FreeArena() passing the arena used to create the RDN.
Related to/duplicate of bug 294538?
This bug would be a candidate to duplicate against bug 294538 if the 
function cited existed and was legitimate, but in this case, it doesn't
exist, and should not exist.  

RDNs are meant to always be created in PLArenaPools.  The only ways to 
deallocate memory allocated from PLArenaPools are to destroy the PLArenaPool
or to "mark" and "release" a portion of the PLArenaPool.  There is no "free"
for a single allocation that has been allocated from a PLArenaPool.  

So, the "work around" described in comment 0 is in fact the solution for 
someone wanting to free an RDN, and we should eliminate the bogus function
declaration to eliminate further confusion.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Priority: -- → P3
Hardware: x86 → All
Summary: CERT_DestroyRDN defined in cert.h but not implemented → Remove declaration of bogus and nonexistent CERT_DestroyRDN function from public NSS header files
Version: unspecified → 3.0
Attachment #8395422 - Flags: review?(emaldona)
Attachment #8395422 - Flags: review?(emaldona) → review+
Assignee: nobody → cykesiopka.bmo
Keywords: checkin-needed
Kai, maybe you can assist with this checkin? :)
Flags: needinfo?(kaie)
https://hg.mozilla.org/projects/nss/rev/2f32f8a4a781
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 3.16.1
Flags: needinfo?(kaie)
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.