Need cancel button after clicking Reset Sync

VERIFIED FIXED in 1.2

Status

Cloud Services
Firefox Sync: UI
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: tchung, Assigned: zpao)

Tracking

({regression})

unspecified
regression
Points:
---
Bug Flags:
blocking-weave1.2 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [weave1.2b3])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
There's no way to exit the merge data window once the user has entered the "Reset Sync" page.   This leaves the user unable to cancel the operation or scroll back to the main window.  Even closing prefpane and reopening the weave tab takes user back to the merge data page.   

The only way to move forward is to merge the data, and people may not want that. 

Possibly a regression from bug 539057.

Repro:
1) Install weave 1.2b3
2) sign in
3) click "Reset Sync"
4) Page lands on merge data window
5) Verify there is no way to cancel the operation or go back to main page without finishing the merge

Expected:
- cancel or back option

Actual:
- merge forward only
(Reporter)

Updated

8 years ago
Keywords: regression
(Reporter)

Updated

8 years ago
Flags: blocking-weave1.2?
(Reporter)

Updated

8 years ago
Whiteboard: [weave1.3b2]

Updated

8 years ago
Whiteboard: [weave1.3b2] → [weave1.2b3]
* Add an Undo or Cancel button in the case where this is clicked
* Do _not_ block on picking an option here (IOW, don't set firstSync to notReady except in the "setting up a new/different account" case.)  if the user closes the window, it's a no-op.
Assignee: nobody → mconnor
Summary: Need start over page when navigating to Reset Sync window → Need cancel button after clicking Reset Sync

Updated

8 years ago
Flags: blocking-weave1.2? → blocking-weave1.2+
Target Milestone: --- → 1.2
Created attachment 437430 [details] [diff] [review]
Patch v0.1

bam!
Assignee: mconnor → paul
Status: NEW → ASSIGNED
Attachment #437430 - Flags: review?(mconnor)
Comment on attachment 437430 [details] [diff] [review]
Patch v0.1

Will also need the following in handleChoice:
> this._resettingSync = false;

Mardak also proposed just calling |this.page = 2;| instead of going through updateWeavePrefs(), which I think would work, you just lose the Weave.Clients.update() call (which might be pretty important, not sure if we do that again later before doing anything with clients)
Comment on attachment 437430 [details] [diff] [review]
Patch v0.1

Not sure on the strings, but we should get a full string review ASAP.
Attachment #437430 - Flags: review?(mconnor) → review+
(In reply to comment #3)
> (From update of attachment 437430 [details] [diff] [review])
> Will also need the following in handleChoice:
> > this._resettingSync = false;

Actually, no I don't (but I'm going to in case the flow changes here). The only way out is to close the window (which will recreate gWeavePane) or to go back & press cancel (which does set it to false). moving forward (Start syncing now) also closes the window.
Pushed http://hg.mozilla.org/labs/weave/rev/bc49ad0a6956
Added a cancel button that only shows on the sync options page when resetting.
Also removed the pref usage, so that resetting is properly cancelable (by pressing cancel, closing the window, or quitting).

(In reply to comment #3)
> (From update of attachment 437430 [details] [diff] [review])
> Will also need the following in handleChoice:
> > this._resettingSync = false;

I did this in setupInitialSync (since that's the same place the startOver button was hidden)
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
verified with Weave 1.2.b4 on Fx 3.6.3
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.