[d2d][grafxbot] SVG rect with border has fuzzy edges on ATI Mobility Radeon HD 4650, Windows 7

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: jgriffin, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

9 years ago
The following reftests fail in hardware accelerated mode on Windows 7 with the ATI Mobility Radeon HD 4650:

fails-if(MOZ_WIDGET_TOOLKIT=="cocoa") == inline--position-relative--01.xhtml[accelerated] inline--position-relative--01-ref.xhtml[accelerated]
http://brasstacks.mozilla.com/resultserv/data/testcase/3808/

fails-if(MOZ_WIDGET_TOOLKIT=="cocoa") == inline--display-inline-block--01.xhtml[accelerated] inline--display-inline-block--01-ref.xhtml[accelerated]
http://brasstacks.mozilla.com/resultserv/data/testcase/3798/

fails-if(MOZ_WIDGET_TOOLKIT=="cocoa") == inline--display-inline--01.xhtml[accelerated] inline--display-inline--01-ref.xhtml[accelerated]
http://brasstacks.mozilla.com/resultserv/data/testcase/3796/

fails-if(MOZ_WIDGET_TOOLKIT=="cocoa") == inline--display-block--01.xhtml[accelerated] inline--display-block--01-ref.xhtml[accelerated]
http://brasstacks.mozilla.com/resultserv/data/testcase/3794/

See links above for test images.  In all cases the differences are visually detectable, but not large; the blue rectangle has a fuzzy edge in the test page, but not the reference page.  The same problem is not observed on this hardware in software-rendered mode, nor on a WinXP VM in hardware-accelerated mode.
I think these may go away once bug 548648 lands.
(In reply to comment #1)
> I think these may go away once bug 548648 lands.

I suspect the same, DirectWrite adds subpixel sizes to glyphs on windows.
Please verify these issues are resolved.
Seems like it's fixed
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.