font size reduced when bullet or numbered list selected or exited

RESOLVED DUPLICATE of bug 250539

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 250539
8 years ago
7 years ago

People

(Reporter: Bill Arrowsmith, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)
Build Identifier: 2.0.0.24 (20100228)

During Message composition, if a bulleted or numbered list is selected, font size drops. If font size is then increased, it stays big until list is exited, then drops again. Note: if bullet list selected on line that's already typed, font size doesn't drop then; but does drop when list exited.
Same font size reduction problem occurs when an indent (or un-indent) is selected.

Reproducible: Always

Steps to Reproduce:
1 select Write, to compose message and begin entering text in Body window
2.Press Enter, to go to new line, followed by bullet list selection
3.continue typing; font size is now reduced
4. increase font size; continue typing
5. then exit list (type Enter twice)
6. continue typing; once again, font size is reduced.
Actual Results:  
(actual results could not be displayed here.  font size changes do not show up here after cut and paste)  But here is the text I tried to paste -- you'll just have to read my words -- the changed text size does not show up here:

Select "Write", then begin typing in message window, like this.
Enter, to go to next line.  Font size is okay.  Now press Enter, followed by bulleted or numbered list,

    * like this.  notice that font size is smaller.
    * it stays small unless increased by user, like this.
    * it will stay large until the list is exited

then it will get small again, like this.

The same thing occurs with the 'indent' feature.  If "Enter" is pressed to go to a new line

    and then "indent" selected, the text gets small. like this.

    However, if 'indent' is selected on an existing line, the text stays the same size.  I will do so on this line. 

But if one selects Enter first, then 'unindent', the result is reduced font size, like this.




  




Expected Results:  
Expected no change in text size when entering or exiting list or indenting or un-indenting.
This report looks a lot like a part of bug 250539; before continuing, could you check if they look to be the same?

If not, please describe one or two ways they differ notably.
Also, can you send a test message to yourself, save it as a file (File -> Save As -> Fileā€¦) and attach it to this bug report using the Add an attachment link? That will help a lot. (Alternatively, attach a screenshot in a similar fashion, probably using Alt-PrtScr on Windows to capture the screenshot and Paint to save it, then attaching it in the same way.)
(Reporter)

Comment 2

8 years ago
This report is, indeed, basically like bug 250539 (which didn't appear on search of 'font size').  And the workaround suggested there under Comment 1 does work here, too -- but only on ENTERING list mode.  I.E., move to new line, start entering first list item and THEN select bullet/number list.  Font size is retained okay.  BUT -- one cannot use that workaround to LEAVE the itemized list.  At that point, the only alternative is to select the larger-text icon.
(In reply to comment #2)
> This report is, indeed, basically like bug 250539
All right, resolving as duplicate accordingly. Thanks, by the way, for reporting this :-)

> (which didn't appear on search of 'font size').
Not sure there's much that can be done about that, except that duplicate bugs such as this one will also show up in search results, which should help matters somewhat. (Specializing the main bug to mention font size isn't really warranted, because that's actually just one of dozens of possible symptoms of the same bug.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 250539

Comment 4

7 years ago
It appears to be inappropriate to require that we relate this problem to number 250539.  That one has gone nowhere for six years.  Worse, the workarounds and suggestions are not useful, since the problem is that the features do not work in an intuitive manner.

The whole point in good software design is that the user's expectations are met in the way they use the software.  If workarounds are needed, then the software is not done.  Let's send this right back up to the coders to fix this little problem, and let's stop considering workarounds.  We all are already doing things in our own workaround manner; each in our own way.

What we want is the editor portion of this fine program brought upon to 1990 standards.  Just a simple, basic sort of rock-solid editor is all that's needed.

Thanks.
You need to log in before you can comment on or make changes to this bug.