Closed Bug 557416 Opened 11 years ago Closed 11 years ago

Remove unnecessary includes and forward declarations of nsIPresShell and nsPresContext

Categories

(Core :: Layout, defect)

defect
Not set
trivial

Tracking

()

RESOLVED FIXED
mozilla1.9.3a5

People

(Reporter: craig.topper, Assigned: craig.topper)

References

Details

Attachments

(2 files, 2 obsolete files)

A lot of unnecessary includes and forward declarations of these two classes have accumulated throughout the tree. At the very least this wastes build time.
This patch cleans up the includes of nsIPresShell. The includes were removed by grepping for "PresShell" and if it didn't show up in the file then I removed the include.

Also converted some includes in header files to use forward declarations if possible to keep includes from spreading.
Attachment #437202 - Flags: review?(roc)
Similar patch for nsPresContext. This patch depends on the nsIPresShell patch.
Attachment #437203 - Flags: review?(roc)
Keywords: checkin-needed
Found some build issues though I could have sworn I built with this patch. Removing checkin-needed tag so I can resolve.
Keywords: checkin-needed
Attached patch Updated patch for nsPresContext (obsolete) — Splinter Review
Added two includes of nsIXPCScriptable.h to fix build failures.
Attachment #437203 - Attachment is obsolete: true
Attachment #437748 - Flags: review?(roc)
Keywords: checkin-needed
Attachment #437748 - Attachment is obsolete: true
http://hg.mozilla.org/mozilla-central/rev/f219b151fc4a
http://hg.mozilla.org/mozilla-central/rev/7d2746bc7471
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a5
Duplicate of this bug: 552244
Duplicate of this bug: 552245
Product: Core → Core Graveyard
Component: Layout: Misc Code → Layout
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.