Blank Page startup should not display the awesomebar screen

VERIFIED FIXED

Status

VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: mfinkle, Assigned: mfinkle)

Tracking

Trunk
x86
Linux
Bug Flags:
in-litmus +

Details

Attachments

(1 attachment)

Created attachment 437206 [details] [diff] [review]
patch

If the user selects "Blank Page" as the start page, don't show the awesomebar screen. From Madhava on IRC:


madhava: my ideal would be to show a blank page, but have the hint in the url bar
madhava: my rationale is based on two things:  1 - I think that's what the option actually suggests (and there's a desktop behavior called the same thing)
madhava: and 2 - part of the reason for the start page at all was confusion about the awesomescreen
madhava: if we just keep showing the awesomescreen, none of that goes away

NOTE: this patch also fixes an error in updateHomePage that kept the "Blank Page" setting from even working. Element.removeChild was being passed null and throwing an error.
Attachment #437206 - Flags: review?(21)
pushed:
http://hg.mozilla.org/mobile-browser/rev/e3e888805abc
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
verified FIXED On builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.4pre) Gecko/20100407 Namoroka/3.6.4pre Fennec/1.1a2pre

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a4pre) Gecko/20100407 Namoroka/3.7a4pre Fennec/1.1a2pre
Status: RESOLVED → VERIFIED
Flags: in-litmus?
litmus testcase https://litmus.mozilla.org/show_test.cgi?id=11661 updated to regression test this bug
Flags: in-litmus? → in-litmus+
bugspam
Assignee: nobody → mark.finkle
You need to log in before you can comment on or make changes to this bug.