Unknown alarm types (i.e AUDIO) show full alarm image in event view

RESOLVED FIXED in 1.0b2

Status

Calendar
Alarms
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Raino Kolk, Assigned: Fallen)

Tracking

Lightning 1.0b1
1.0b2

Details

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3pre) Gecko/20100330 Ubuntu/9.10 (karmic) Namoroka/3.6.3pre
Build Identifier: Lightning/1.0b2pre (nightly 05.march 2010)

I have connected lighting with network calendar that uses ICS format. But reminder not working. Lighting not understands reminder, not updates reminder and not reminds. In Calendar view I can see envelope, bell and bell with red sign icons. 
Same icalendar works perfectly with Sunbird/0.9

 

Reproducible: Always

Steps to Reproduce:
1.I have exchange server
2.I have Davmail gateway (this provides exchange in ICS format)
3.I connect Lighting with Davmail
4.Events are imported to lighting
Actual Results:  
Events are all imported but reminder data is imported incorrectly. event shows bell, bell with red sign and envelope icons. Cant update reminder and lighting not reminds when needed.
Same thing works perfectly with Sunbird.

Expected Results:  
Should import correct reminder. Should be abel to update reminder info, should remind when needed.
(Reporter)

Updated

8 years ago
Version: unspecified → Lightning 1.0b1

Comment 1

8 years ago
Related to/duplicate of bug 527960?
Raino, could you copy a sample event with alarm and paste it here in the iCalendar format? Most probably is has some properties that are either invalid or not supported by Lightning.
Component: Lightning Only → Alarms
QA Contact: lightning → alarms
(Reporter)

Comment 3

8 years ago
One event from vcalendar

BEGIN:VEVENT

CREATED:20100407T105632Z

LAST-MODIFIED:20100407T110005Z

DTSTAMP:20100407T102839Z

UID:5E0AAFB0FFCD04C3C22576FD0024064C-Lotus_Notes_Generated

SUMMARY:Some summary
X-CALENDARSERVER-ACCESS:PUBLIC

CLASS:PUBLIC

ORGANIZER;RSVP=FALSE;CN=Some person:mailto:some email
ATTENDEE;RSVP=FALSE;CN=Raino Kolk;PARTSTAT=ACCEPTED;ROLE=REQ-PARTICIPANT:ma

 ilto:some email
X-MOZ-LASTACK:20100407T110005Z

DTSTART;TZID=FLE:20100407T143000

DTEND;TZID=FLE:20100407T170000

X-MOZ-LASTACK:20100407T110005Z

TRANSP:OPAQUE

SEQUENCE:0

DESCRIPTION;ALTREP="CID:<FFFF__=4DBBFC6EDFB780DC8f9e8a93df938690918c4DB@>":

Some description
LOCATION:@ Somewhere
X-LOTUS-BROADCAST:FALSE

X-LOTUS-UPDATE-SEQ:1

X-LOTUS-UPDATE-WISL:$S:1;$L:1;$B:1;$R:1;$E:1;$W:1;$O:1;$M:1

X-LOTUS-NOTESVERSION:2

X-LOTUS-NOTICETYPE:I

X-LOTUS-APPTTYPE:3

X-LOTUS-CHILD_UID:5E0AAFB0FFCD04C3C22576FD0024064C

X-MOZ-RECEIVED-SEQUENCE:0

X-MOZ-RECEIVED-DTSTAMP:20100406T063640Z

X-MOZ-GENERATION:1

BEGIN:VALARM

TRIGGER;VALUE=DURATION:-PT30M

DESCRIPTION:Mozilla Alarm: Some alarm
ACTION:AUDIO

ATTACH;VALUE=URI:

END:VALARM

END:VEVENT

END:VCALENDAR
(Reporter)

Comment 4

8 years ago
I must mention that problem exists only in lighting not in sunbird.
(Reporter)

Comment 5

8 years ago
Created attachment 439674 [details]
One event view in lighting

This is hot event looks in Lighting
(Reporter)

Comment 6

8 years ago
Created attachment 439675 [details]
One event view in Sunbird

In sunbird event is correct
(Assignee)

Comment 7

8 years ago
The event you mention has two issues. It contains two X-MOZ-LASTACK entries, which seems to be bug 539923. Then it contains an AUDIO alarm that is a bit malformed:

> BEGIN:VALARM
> TRIGGER;VALUE=DURATION:-PT30M
> DESCRIPTION:Mozilla Alarm: Some alarm
> ACTION:AUDIO
> ATTACH;VALUE=URI:
> END:VALARM

We don't support (nor set) AUDIO alarms, so I assume the lotus server messed with this alarm somehow. Second, the attached alarm sound (ATTACH property) doesn't contain a valid uri to an alarm.

Not quite sure why the whole alarm image is shown, I guess we could be more graceful with that. Should be a minor issue though.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Reminder not working with icalendar(ICS) → Unknown alarm types (i.e AUDIO) show full alarm image in event view
(Assignee)

Comment 8

8 years ago
Created attachment 440153 [details] [diff] [review]
Fix - v1
Attachment #440153 - Flags: review?(Mozilla)
(Assignee)

Comment 9

8 years ago
Comment on attachment 440153 [details] [diff] [review]
Fix - v1

This patch should make us a bit more robust on the image side. For unknown
alarms, we still show "Custom..." in the alarm dialog and an empty custom
reminder dialog, but there's not really much we can do about it.
(Assignee)

Comment 10

8 years ago
Well, thats not quite right. Of course we can, but I think that should happen in a separate bug. I've filed bug 560457 for this.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: x86 → All
Comment on attachment 440153 [details] [diff] [review]
Fix - v1

patch looks good.

I get no Icon on the event after the patch.
First I thought this is not right, but because the unknown alarm won't go off in lightning, i believe we can live with this.

But this point should adressed in the spinoff bug from the previous comment.

r=markus
Attachment #440153 - Flags: review?(Mozilla) → review+
(Assignee)

Comment 12

8 years ago
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/8313958528c6>
-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0b2
You need to log in before you can comment on or make changes to this bug.