Can't edit selected text at end of TEXTAREA line

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: h.b.furuseth, Assigned: mozeditor)

Tracking

({regression})

Trunk
All
Solaris
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm++][dogfood+], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; SunOS 5.7 sun4u)
BuildID:    2000100610

If I use the mouse to select text to the end of a TEXTAREA line,
I can't always delete or edit it.

Reproducible: Sometimes
Steps to Reproduce:
1. Go to a textarea and type a few lines with several words each.
2. Select the text to the end of a line.
3. Type something or press Delete.
4. Mouse the cursor to before the last character on the line.
5. Push the cursor-forward key.

Actual Results:  (3) and (5) may do nothing.

Expected Results:  							

There are other problems, but these seem easiest to reproduce
(or maybe they are just easiest to notice:-)
- After a bit of mousing and typing, the cursor keys may not work
  at all.
- Bug 35952 ("spacebar scrolls page) is active.
- Mozilla crashed when I was about to submit
  this bug.  Maybe that was because I had experimented
  with the problem.  Sorry, no coredump, but the output ended with:
didnt get here
****** returning null 2
dragstart
didnt get here
****** returning null 2
X Error of failed request:  BadAtom (invalid Atom parameter)
  Major opcode of failed request:  17 (X_GetAtomName)
  Atom id in failed request:  0x72006e
  Serial number of failed request:  253921
  Current serial number in output stream:  253921
(Reporter)

Comment 1

18 years ago
Oops - I think it was just the bug-report window which crashed, not
all of Mozilla.  At least there was a Mozilla window left (without
the bug report), and I don't think I had two Mozillas running.

Comment 2

18 years ago
reassigning
Assignee: rods → beppe

Comment 3

18 years ago
confirmed, linux, trunk.
Select last half of URL bar and try to replace the text,
you can't.  Regression.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Comment 4

18 years ago
I cannot use the Location bar with this bug, marking dogfood.
Keywords: dogfood

Updated

18 years ago
Assignee: beppe → kin

Comment 5

18 years ago
assigning to kin for debug

Comment 6

18 years ago
Kin, do you have the time to fix this before RTM?  It really sucks for a lot of
people.

Comment 7

18 years ago
I can't get this to happen in my current trunk build (which does, however, have
some changes in it, so I'll try to figure out what those are and if anything
might be blocking my seeing this bug).

Joe, however, says he may have seen something like this earlier today -- he got
an editor transaction error.

Comment 8

18 years ago
To answer don's question ... if I can reproduce it, I can look at it.

Is this bug on the Netscape_20000922_BRANCH or the trunk? There was a big 
landing of the NO_XIF_20000911_BRANCH on the trunk this weekend, so if it's 
only on the trunk, it may or may not, be related to that.

Mcafee says he can't type in any text widgets in his Linux trunk build, but 
akkana can? I can't reproduce this problem in my trunk or branch Win32 build.
Status: NEW → ASSIGNED
Target Milestone: --- → M19

Comment 9

18 years ago
I get this assertion when I try to delete the selection:

###!!! Break: at file nsEditor.cpp, line 1163
###!!! ASSERTION: selection not collapsed after delete selection.:
'PR_TRUE==isCollapsed', file nsTextEditRules.cpp, line 913

jfrancis sees this in one case on the Mac, but not this
particular selection case.

Comment 10

18 years ago
Works for me on mozilla win32 trunk.
Trying "Editor" component instead of "Form Submission",
if you've got a better component please change it.
Component: Form Submission → Editor
(Assignee)

Updated

18 years ago
Keywords: rtm
(Assignee)

Comment 11

18 years ago
This is a real bug, but I don't see any signs it is related to noxif.  I have a 
fix for it.  Attaching patch momentarily.  

Comment 12

18 years ago
-> joe. 

rtm+ this bug on the basis of serious usability issues, esp. on linux, and the 
brevity and safety of the patch (which is coming).
Assignee: kin → jfrancis
Status: ASSIGNED → NEW
Whiteboard: [rtm+]
(Assignee)

Comment 13

18 years ago
Created attachment 16580 [details] [diff] [review]
diff to layout/base/src/nsContentIterator.cpp

Comment 14

18 years ago
Occurs on all platforms.
sr=sfraser on the patch.
Hardware: Sun → All

Comment 15

18 years ago
PDT marking [rtm++]
Whiteboard: [rtm+] → [rtm++]

Comment 16

18 years ago
We've gotta' be able to edit text areas.
Marking dogfood-plus.
Whiteboard: [rtm++] → [rtm++][dogfood+]
(Assignee)

Comment 17

18 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 18

18 years ago
verified in 11/1 build.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 19

17 years ago
The bug is back!
Can't edit textarea, location bar, or 'open web location' window.

Build ID 2001060622 (Solaris), though I seem to remember
I noticed it some time ago but forgot to report it then.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 20

17 years ago
Which bug is back? You say you can't edit.  That's not exactly what this bug
originally said.  Please be specific.  I am able to edit text widgets in a
6/6/01 build fine.  
(Reporter)

Comment 21

17 years ago
Um.  You are right, it's worse now - maybe it should be a different bug.
Let's see --

$ uname -a
SunOS bombur.uio.no 5.8 Generic_108528-03 sun4u sparc
$ mozilla "http://bugzilla.mozilla.org/show_bug.cgi?id=55748" &

I cannot place a visible cursor in the Summary field, location bar, or
the "open web location" window at all, and cannot type anything there.

I can select text in these fields (drag left mouse button), but can't
edit or delete the selected text.  I *can* paste in text with the middle
mouse button.

...hey, after I started netscape, typed this report, and went back to the
mozilla window, I *can* edit and type in the "Additional Comments" part in
Mozilla!  The problem still holds for the other fields though: if I try to
type in the Summary field or location bar, the text now appears in
Additional Comments.  Seems to be a focus problem.
If I open a New Web Location box, I still can't type anything there.
When I close it, nothing I try to type in the Summary field appears.
When I click on Additional Comments, I can type there, and what I
type in Summary again appears in Additional Comments.

I've tried to start a 2nd mozilla and then a 2nd netscape to reproduce
that, but I cant.  In the 2nd mozilla I can place the cursor it the
Additional Comments field, but can't type anything.  I don't remember
if I tested that in the 1st mozilla.
(Reporter)

Comment 22

17 years ago
oops, I forgot to say that the _rest_ of my description still
applies to that 2nd mozilla: No typing/editing in the other fields.

Comment 23

17 years ago
I see the can't-select-last-line-of-text in plain text compose,
this problem has been there for a few weeks at least.

Comment 24

17 years ago
Hallvard, the problems you describe sound like focus problems, so lets file a 
different bug and leave this one closed as fixed since it was caused by 
something totally different.

Mcafee, mjudge knows about that problem, it is a bug in selection, I don't know 
if he filed a bug about though.

Comment 25

17 years ago
marking as fixed, Hallvard, please opena  new bug for the reported issue
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED

Comment 26

17 years ago
Cannot reproduce. Verifying on build 07/24/05 - 0.9.2 on linux red hat
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.