The position of the auto hide Menu Bar is random, when enabled Tabs over the Navigation Toolbar

RESOLVED DUPLICATE of bug 555987

Status

()

Core
XUL
P2
normal
RESOLVED DUPLICATE of bug 555987
8 years ago
8 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 beta2+)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US;
                        rv:1.9.3a4pre) Gecko/20100406 Minefield/3.7a4pre
ID:20100406003858
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US;
                        rv:1.9.3a4pre) Gecko/20100406 Minefield/3.7a4pre
ID:20100406003858

When enabled auto hide Menu Bar and Tabs over the Navigation Toolbar,
I toggle menubar by ALT key,

*Menu Bar appears on top of Tab bar and at the bottom of Tab Bar .

Menu Bar position  should be same position in existing window and new window.

Reproducible: Always

1. Start Minefield with new profile
2. View > Toolbars > "Tabs on Top" checked 
    *Confirm position of Menubar --- Menu Bar is at the BELLOW of Tab Bar.
3. View > Toolbars > "Menu Bar" unchecked
4. Toggle mentbar by ALT key,
     *Confirm position of Menubar. --- Menu Bar is on the TOP of Tab Bar.
5. File > New Window (CTRL +N)
6. Toggle mentbar by alt key in new window,
     *Confirm position of Menubar.--- Menu Bar is at the BELLOW of Tab Bar.
7. View > Toolbars > "Menu Bar" checked
    *Confirm position of Menubar. --- Menu Bar is on the TOP of Tab Bar.

Actual Results:
 Toggle Menub Bar by ALT key,
 Menu bar position  is random.

Expected Results:
 Menu bar position  should be same position in existing window and new window.
(Reporter)

Updated

8 years ago
Blocks: 544815
No longer blocks: 557468

Updated

8 years ago
Status: UNCONFIRMED → NEW
Component: Tabbed Browser → XUL
Ever confirmed: true
Product: Firefox → Core
QA Contact: tabbed.browser → xptoolkit.widgets

Comment 1

8 years ago
I can confirm this.

Comment 2

8 years ago
May be this is not the right place to say it, but IMO tabs should always be _under_ menu bar.

Comment 3

8 years ago
(In reply to comment #2)
> May be this is not the right place to say it, but IMO tabs should always be
> _under_ menu bar.

Well, with the option integrated, it's now up to the individual user to decide, no matter what you prefer. And no, this is not the right place to discuss this. Try the newsgroups.

Comment 4

8 years ago
OS: Win XP x86 SP2

I can confirm this as well. 

I don't believe that this should be user preference. The menubar does not change from tab-to-tab and therefore should not be moveable. This is also windows standard.

Comment 5

8 years ago
Requesting blocking as this is very annoying and gives a very unpolished look and feel with the toolbars jumping around randomly.
blocking2.0: --- → ?

Updated

8 years ago
Duplicate of this bug: 564136

Comment 7

8 years ago
is this fixed by bug 564187 ?
The underlying issue remains.
In what part of the code would you expect the underlying issue to be?  Why is this a Core bug rather than a Firefox bug?  How does the Firefox code move the toolbars/menubars around?
I'm not sure why the position was random prior to bug 564187 (the menu bar should always have been below the tab bar), but it wasn't caused by Firefox, and I expect this to be related to bug 555987.
blocking2.0: ? → beta1+
Priority: -- → P2

Updated

8 years ago
Duplicate of this bug: 569980

Updated

8 years ago
No longer blocks: 544815
Oops...
Blocks: 544815
Bumping this to beta2 per beta re-triage with dbaron.  If this should indeed block beta1, please re-nom.

Can we get this assigned?
blocking2.0: beta1+ → beta2+
We need to test if bug 555987 solved this -- probably by backing out attachment 443880 [details] [diff] [review] locally, since we don't have a reduced testcase.
I tested on the most recently night, following the STR it looks fixed.  Menu Bar stays above Tabs On Top when using Autohide in the same window and in a new window.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:2.0b2pre) Gecko/20100629 Minefield/4.0b2pre
Bug 564187 masked this, so testing in a vanilla nightly isn't useful.
I reverted attachment 443880 [details] [diff] [review] and couldn't reproduce the bug.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 555987
You need to log in before you can comment on or make changes to this bug.