Status

Testopia
Import/Export
UNCONFIRMED
8 years ago
8 years ago

People

(Reporter: Markus, Assigned: Greg Hendricks)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; es-ES; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: bugzilla 3.4.6 testopia latest stable from cvs

when i want to export test cases through the test cases tab in testopia dashboard i select one or more testcases and click on export test cases to csv. then i download the csv but it only contains the column names, no data.

The XML just contains
<?xml version="1.0" encoding="UTF-8" ?>
<tr:testopia
 version="2.3"
 xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
 xmlns:tr="http://www.mozilla.org/projects">

</tr:testopia>

Reproducible: Always

Steps to Reproduce:
1. go to testopia dashboard
2. go to test cases
(optional select one or more test cases)
3. click on export test cases to XML
4. open xml with editor
Actual Results:  
"empty" file is downloaded

Expected Results:  
structure should be filled with data

i tried it with bugzilla 3.4.4, then updated to 3.4.6 and latest stable testopia but still no success...
(Assignee)

Comment 1

8 years ago
Please be sure that you have installed all the optional Perl modules as listed during checksetup.
(Reporter)

Comment 2

8 years ago
i think that should be alright:

root@it-scmsrvr:/var/www/bugzilla3# ./checksetup.pl
* This is Bugzilla 3.4.6 on perl 5.10.0
* Running on Linux 2.6.31-20-generic-pae #58-Ubuntu SMP Fri Mar 12 06:25:51 UTC 2010

Checking perl modules...
Checking for              CGI.pm (v3.33)   ok: found v3.43
Checking for          Digest-SHA (any)     ok: found v5.45
Checking for            TimeDate (v2.21)   ok: found v2.22
Checking for            DateTime (v0.28)   ok: found v0.53
Checking for   DateTime-TimeZone (v0.71)   ok: found v1.10
Checking for                 DBI (v1.41)   ok: found v1.609
Checking for    Template-Toolkit (v2.22)   ok: found v2.22
Checking for          Email-Send (v2.00)   ok: found v2.197
Checking for          Email-MIME (v1.861)  ok: found v1.863
Checking for Email-MIME-Encodings (v1.313)  ok: found v1.313
Checking for Email-MIME-Modifier (v1.442)  ok: found v1.444
Checking for                 URI (any)     ok: found v1.37
Checking for                JSON (v2.10)   ok: found v2.15
Checking for           Text-Diff (v0.35)   ok: found v1.37
Checking for          GD-Graph3d (v0.63)   ok: found v0.63

Checking available perl DBD modules...
Checking for              DBD-Pg (v1.45)   ok: found v2.16.1
Checking for           DBD-mysql (v4.00)   ok: found v4.011
Checking for          DBD-Oracle (v1.19)    not found

The following Perl modules are optional:
Checking for                  GD (v1.20)   ok: found v2.39
Checking for               Chart (v1.0)    ok: found v2.4.1
Checking for         Template-GD (any)     ok: found v1.56
Checking for          GDTextUtil (any)     ok: found v0.86
Checking for             GDGraph (any)     ok: found v1.44
Checking for            XML-Twig (any)     ok: found v3.34
Checking for          MIME-tools (v5.406)  ok: found v5.427
Checking for         libwww-perl (any)     ok: found v5.829
Checking for         PatchReader (v0.9.4)  ok: found v0.9.5
Checking for          PerlMagick (any)     ok: found v6.5.1
Checking for           perl-ldap (any)     ok: found v0.39
Checking for         Authen-SASL (any)     ok: found v2.13
Checking for          RadiusPerl (any)     ok: found v0.17
Checking for           SOAP-Lite (v0.710.06) ok: found v0.710.10
Checking for         HTML-Parser (v3.40)   ok: found v3.61
Checking for       HTML-Scrubber (any)     ok: found v0.08
Checking for Email-MIME-Attachment-Stripper (any)     ok: found v1.316
Checking for         Email-Reply (any)     ok: found v1.202
Checking for         TheSchwartz (any)     ok: found v1.07
Checking for      Daemon-Generic (any)     ok: found v0.61
Checking for            mod_perl (v1.999022) ok: found v2.000004
Checking for            Text-CSV (v1.06)   ok: found v1.16
Checking for XML Schema Validator (v1.10)   ok: found v1.10
Checking for   XML Schema Parser (any)     ok: found v1.01
Checking for            XML Twig (any)     ok: found v3.34
Reading ./localconfig...

OPTIONAL NOTE: If you want to be able to use the 'difference between two
patches' feature of Bugzilla (which requires the PatchReader Perl module
as well), you should install patchutils from:

    http://cyberelk.net/tim/patchutils/

Checking for           DBD-mysql (v4.00)   ok: found v4.011
Checking for           MySQL (v4.1.2)  ok: found v5.1.37-1ubuntu5.1

Removing existing compiled templates...
Precompiling templates...done.
Fixing file permissions...

Checking Testopia setup ...
Done checking Testopia setup.
You need to log in before you can comment on or make changes to this bug.