Closed Bug 557616 Opened 12 years ago Closed 11 years ago

unable to run cfx testall (/usr/bin/env: bad interpreter: Permission denied)

Categories

(Add-on SDK Graveyard :: General, defect, P1)

x86
Linux
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jmaher, Assigned: myk)

Details

I am trying to get the jetpack SDK up and running and as a first step I am trying to run the out of the box tests.

I do this:
* download sdk and unpack it locally
* cd to unpacked directory
* 'source bin/activate'
* 'python bin/cfx testall'
* result: firefox is launched (fresh instance, no url and default tab) and it sits there.

in irc adw was curious about my experience.  I found that the documented method for cfx was not working on my machine (Ubuntu 9.10):

(jetpack-sdk-0.2)joel@joel-ubuntu:~/Downloads/jetpack-sdk-0.2$ cfx testall
bash: /home/joel/Downloads/jetpack-sdk-0.2/bin/cfx: /usr/bin/env: bad interpreter: Permission denied
(jetpack-sdk-0.2)joel@joel-ubuntu:~/Downloads/jetpack-sdk-0.2$ sudo cfx testall
[sudo] password for joel: 
sudo: cfx: command not found
(jetpack-sdk-0.2)joel@joel-ubuntu:~/Downloads/jetpack-sdk-0.2$


I am also running python 2.6.4.  If there is something else I should do or if you need more information, please let me know.
What's the output of `which python` on your system?
joel@joel-ubuntu:~$ which python
/usr/bin/python
joel@joel-ubuntu:~$
How about `which env` and `env python`?
joel@joel-ubuntu:~$ which env
/usr/bin/env
joel@joel-ubuntu:~$ env python
Python 2.6.4 (r264:75706, Dec  7 2009, 18:45:15) 
[GCC 4.4.1] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> quit
Use quit() or Ctrl-D (i.e. EOF) to exit
>>>
Hmm, strange, I'm not sure what's going on.  I can't reproduce on my Ubuntu Linux 9.10 system.
Summary: unable to run cfx testall → unable to run cfx testall (/usr/bin/env: bad interpreter: Permission denied)
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
Version: 0.2 → unspecified
Joel: can you still reproduce this problem with the latest version of the SDK?
Whiteboard: [triage:followup]
Setting priority based on the assumption that we'll be able to reproduce it.  It sounds like a really bad problem that we should fix!
Priority: -- → P1
Whiteboard: [triage:followup]
Target Milestone: --- → 1.0
Assignee: nobody → myk
(In reply to comment #0)
> * 'python bin/cfx testall'
> * result: firefox is launched (fresh instance, no url and default tab) and
> it sits there.

This symptom is the one that happens when using firefox 3.6.
The addon-sdk is only compatible with Firefox 4.

Can you try with the following command ?
  cfx testall -b /path/to/a/firefox4/binary
with the latest sdk, and a mozilla-central build, I am able to run these tests just fine.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.