when tab bar doesn't overflow you can not drop tab all the way to the left

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
trivial
RESOLVED WORKSFORME
8 years ago
4 years ago

People

(Reporter: tabmix.onemen, Unassigned)

Tracking

({regression})

Trunk
Firefox 3.7a4
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
when tab bar doesn't overflow you can not drop tab all the way to
the left.

this is regression from Bug 554809 - The drop indicator is not centered when dragging tabs along the tab bar

when ever we drag over the 3px margin the drag indicator disappear

if you bring back -moz-padding-start: 3px;
.tabbrowser-tabs:not([overflow="true"]) {
  -moz-padding-start: 3px;
}

then you can fix the drag indicator position by (this is for left to right):
add
+ var ibRect = ind.parentNode.getBoundingClientRect();


replace
var minMargin = scrollRect.left - rect.left;
with
var minMargin = scrollRect.left - rect.left - ibRect.left;

replace twice
newMargin = tabRect.right - rect.left;
with
newMargin = tabRect.right - rect.left - ibRect.left;
Blocks: 554809

Comment 1

4 years ago
I would like to work on this bug and it would be nice if you could assign this bug to me.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(In reply to kcarchana77 from comment #1)
> I would like to work on this bug and it would be nice if you could assign
> this bug to me.

Hi Kcharchana. Thank you for your interest. As it looks like this bug got fixed a long time ago. So there is no need for work anymore. I would suggest you are looking for some other bug to fix. Let us know if you found one or if you need help.

Comment 3

4 years ago
First of all, thanks for showing interest in helping me out. I would surely need that.

I have got assigned to another bug which is https://bugzilla.mozilla.org/show_bug.cgi?id=485499, but I have got no idea where to start to fix that bug. It would be nice if someone could help me in that. And also I am interested to fix more bugs, and I am looking for more bugs. If anyone can help me to get assigned to more bugs, then I would be glad to help.
You need to log in before you can comment on or make changes to this bug.