A11y should use nsImageMapUtils

RESOLVED FIXED in mozilla5

Status

()

Core
Disability Access APIs
--
trivial
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Ms2ger, Assigned: Ms2ger)

Tracking

(Blocks: 1 bug)

Trunk
mozilla5
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

8 years ago
Created attachment 437524 [details] [diff] [review]
Fix

A11y should use nsImageMapUtils::FindImageMap to find image maps, to avoid duplicating code. Fix attached.
Attachment #437524 - Flags: review?(surkov.alexander)

Comment 1

8 years ago
Comment on attachment 437524 [details] [diff] [review]
Fix

r=me, thanks
Attachment #437524 - Flags: review?(surkov.alexander) → review+
(Assignee)

Updated

8 years ago
Keywords: checkin-needed

Updated

8 years ago
Blocks: 389800

Comment 2

8 years ago
landed on 1.9.3 0 - http://hg.mozilla.org/mozilla-central/rev/e88d2327e25d
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED

Comment 3

8 years ago
backed out - http://hg.mozilla.org/mozilla-central/rev/85454945336e

Thunderbird compilation errors (http://tinderbox.mozilla.org/showlog.cgi?log=Thunderbird/1270732140.1270733069.6613.gz):

../src/base/libaccessibility_base_s.a(nsAccessibilityService.o): In function `nsAccessibilityService::CreateHTMLImageAccessible(nsIFrame*, nsIAccessible**)':
/buildbot/comm-central-trunk-bloat-linux/build/mozilla/accessible/src/base/nsAccessibilityService.cpp:663: undefined reference to `nsImageMapUtils::FindImageMap(nsIDocument*, nsAString_internal const&)'
/usr/bin/ld: libaccessibility.so: hidden symbol `nsImageMapUtils::FindImageMap(nsIDocument*, nsAString_internal const&)' isn't defined
/usr/bin/ld: final link failed: Nonrepresentable section on output
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I think the bustage would affect any non-shared, non-libxul build.

I think the issue is the nsImageMapUtils::FindImageMap obviously has hidden visibility. For libxul and static builds this doesn't matter because accessibility gets linked in with content and layout into one big shared library.

For non-libxul builds (which afaik FF developers still frequently use as well as TB tinderboxes) accessibility is a different shared library, and hence can't access the hidden function.
(Assignee)

Updated

7 years ago
Depends on: 589148
(Assignee)

Updated

7 years ago
Whiteboard: [needs landing]
Isn't this still going to break non-libxul builds?
Do we need a FindImageMapExternal here?
(Assignee)

Comment 7

7 years ago
(In reply to comment #5)
> Isn't this still going to break non-libxul builds?

Yes, hence the dependency on the bug to kill --disable-libxul. Maybe I should have used [waiting for branch] instead...
(Assignee)

Updated

7 years ago
Depends on: 610267
(Assignee)

Comment 8

7 years ago
Created attachment 521560 [details] [diff] [review]
Patch for checkin
Attachment #437524 - Attachment is obsolete: true
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
Whiteboard: [needs landing]
(Assignee)

Updated

7 years ago
Depends on: 581644
Ms2ger, the patch in comment 8 doesn't seem to apply to m-c...
Whiteboard: not-ready-for-cedar
(Assignee)

Comment 10

7 years ago
Did it have bug 581644 at that point?
Status: REOPENED → ASSIGNED
Whiteboard: not-ready-for-cedar
Hmm.  Probably not.  I'll try again tonight.
Ugh.  I missed the fact that this last attachment had a checkin comment but no From line.  Sorry about that.... :(
http://hg.mozilla.org/projects/cedar/rev/b4ffbb84a880
Flags: in-testsuite-
Whiteboard: fixed-in-cedar

Comment 14

7 years ago
http://hg.mozilla.org/mozilla-central/rev/b4ffbb84a880
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago7 years ago
No longer depends on: 610267
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: fixed-in-cedar
Target Milestone: --- → mozilla2.2
You need to log in before you can comment on or make changes to this bug.