When the installer imported Eudora 7 files, several problems occurred. I unwittingly intalled the old Eudora 8.0.0b5, but cannot see in the release reports any evidence that these problems have been solved.

RESOLVED WORKSFORME

Status

Penelope
Installer
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: John Rose, Assigned: Matt Dudziak)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9 (.NET CLR 3.5.30729)
Build Identifier: Eudora 8.0.0b5 

Here are the problems I noted:

a. Saved unsent mail in the Eudora 7 Outbox was imported into the Eudora 8 Outbox just like sent mail. These messages should be imported into the "Drafts" folder.

b. Sent mail in the folders other than Inbox was imported marked as unread, which had to be corrected folder by folder. Why not mark what is read as read and what is not read as unread for all folders, not only the Inbox?

c. At least one apparently well-formed message addressed to me and 4 other addresses was imported with 5 times the first address as recipients but not the other addresses. I could provide you with this message, am looking out for others in my imported mail but have not found any more yet.

d. A large number of messages which had been sent by me (located in different folders) came in tagged "Personal" as well as having their title in italics. I did not have that category in my data and this attribution is annoying since not true (mail is not Personal just because sent by the user), the italics are good enough to identify outgoing messages.

Reproducible: Didn't try




If I get feedback from you on which of the above are still potential problems with the latest version of Eudora 8, I am ready to try to reproduce in a test installation as needed.
(Assignee)

Comment 1

8 years ago
You should have used the latest version.

a.: I am not sure that putting the messages in Drafts would be right thing to do. Yes, they are drafts, but they are in the user's OUT mailbox in Eudora 7 and should be in the OUT mailbox in Eudora 8, IMHO.

b. Fixed in latest version

c. I would like a copy of the message if you don't mind. Please send to mozilla-bugs (at) qualcomm.com


d. I believe this was also fixed in one of the most recent releases.

Thanks, Matt
(Reporter)

Comment 2

8 years ago
Thanks Matt,

I wanted to install the latest version, but when I Googled for a Eudora 8 download I got to a site called Softonic which promoted and provided 8.0.0b5. I subsequently upgraded to Eudora 8.0b9 from the official site, will be more careful in the future.

Can we discuss point a. a bit more? Eudora 7 has no draft facility. When you save a message you are working on, it automatically goes into the Outbox. It is easy to find these drafts to work on them by sorting on the column for unsent mail. When the Eudora 7 Outbox is imported, there seems to be no way to tell the drafts from the sent messages. I had to go to my Eudora 7, list the messages then search for them individually in Eudora 8 and move them into the Drafts folder. IMHO this should be handled in standard fashion by the installer.

Glad that b.and d. have been solved. Concerning c., I can't find this message, and the message which I am almost certain is the one, now reads correctly. I think there is a good chance that this problem which occurred in 8.0.0b5 was fixed in 8.0b9 (i.e. it concerned reading and not importing). Will get back to you if the problem recurs. Best regards, John
(Assignee)

Comment 3

8 years ago
I've opened another bug for item 'a'. See https://bugzilla.mozilla.org/show_bug.cgi?id=559104

As for the download, for the foreseeable future all Eudora releases will be available on http://eudora.com/ (currently in http://eudora.com/betas/). That's the best place to get Eudora 8.

I think I'll close this bug as I suspect the remaining problems are fixed. Please correct me if I am wrong.

Matt
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

8 years ago
I recommend not closing, but rather adding my point a (the only one not solved) to the active bug list.

I said on 7 April: "Eudora 7 has no draft facility. When you save a message you are working on, it automatically goes into the Outbox. It is easy to find these drafts to work on them by sorting on the column for unsent mail. When the Eudora 7 Outbox is imported, there seems to be no way to tell the drafts from the sent messages. I had to go to my Eudora 7, list the messages then search for them individually in Eudora 8 and move them into the Drafts folder. IMHO this should be handled in standard fashion by the installer."

Saved mail in the Eudora 7 outbox means draft messages which have not been sent, and should clearly be imported into the drafts folder in Eudora 8. This bug could be called "Proper treatment of draft messages when importing from classic Eudora"

Thanks and best regards, John
You need to log in before you can comment on or make changes to this bug.