crash if I select text or image on a page and I start to drag it

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: inekman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)

When I select some text or an image (probably other thigns too), Firefox crashes.

Reproducible: Always

Steps to Reproduce:
1. Go on a website with text 
2. Select something
3. Try to drag the selection
Actual Results:  
Firefox crashes :

---------------------------
firefox.exe - Erreur d'application
---------------------------
L'instruction à "0x7c9164e6" emploie l'adresse mémoire "0xd9d36166". La mémoire ne peut pas être "read".


Cliquez sur OK pour terminer le programme.
Cliquez sur Annuler pour déboguer le programme
---------------------------
OK   Annuler   
---------------------------

Expected Results:  
We must be able to drag the selection and drop it somewhere.

Comment 1

8 years ago
Does the crash still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Managing+profiles

Please provide a crash id or stacktrace -> https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.4pre) Gecko/20100403 Namoroka/3.6.4pre

Works for me.
(Reporter)

Comment 3

8 years ago
(In reply to comment #1)
> Does the crash still occur if you start Firefox in Safe Mode?
> http://support.mozilla.com/en-US/kb/Safe+Mode

I tried this after I reported the bug here and I had the same error message.

> How about with a new, empty profile?
> http://support.mozilla.com/en-US/kb/Managing+profiles

I don't know if this is the same, but I uninstalled Firefox, restarted my computer, I made a new setup and this fixed the problem...

> Please provide a crash id or stacktrace ->
> https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report

I will remember to provide a stacktrace if I can reproduce the error.

Do I need to mark this "bug" as RESOLVED ?

Comment 4

8 years ago
Glad you aren't experiencing this issue any more. Closing bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

8 years ago
Hello, 

The bug has come back. I am going to make the necessary to provide you a stacktrace or a crash id by following your link.
(Reporter)

Comment 6

8 years ago
Created attachment 441735 [details]
WinDbg stacktrace log file

Comment 7

8 years ago
Comment on attachment 441735 [details]
WinDbg stacktrace log file

sorry, firefox was already running. if you want to start windbg after firefox is running, then you need to attach to the existing process.

0:000> .tlist
 0n2668 firefox.exe
  0n724 windbg.exe
 0n2416 firefox.exe

the instructions assume you're starting firefox from windbg. we'll try to improve the instructions....
Attachment #441735 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.