Should not support hspace, vspace on canvas

RESOLVED FIXED

Status

()

Core
Canvas: 2D
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Ms2ger, Assigned: Ms2ger)

Tracking

Trunk
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

8 years ago
Created attachment 437597 [details]
Testcase
(Assignee)

Comment 1

8 years ago
Created attachment 437600 [details] [diff] [review]
Patch v1

All of this can go.
Attachment #437600 - Flags: review?(Olli.Pettay)

Comment 2

8 years ago
Comment on attachment 437600 [details] [diff] [review]
Patch v1

>diff --git a/content/html/content/reftests/557840-ref.html b/content/html/content/reftests/557840-ref.html
>new file mode 100644
>--- /dev/null
>+++ b/content/html/content/reftests/557840-ref.html
>@@ -0,0 +1,3 @@
>+<!doctype html>
>+<title>Canvas and hspace, vspace</title>
>+<canvas style=background:black></canvas>
Could you have style="background: black;" here and elsewhere.

This looks ok to me, but in this case I'd ask
what Jonas and/or Vlad say, at least to inform them about this change.
See https://bugzilla.mozilla.org/show_bug.cgi?id=288714&mark=34#c34

Nowadays canvas element doesn't inherit img element
http://www.whatwg.org/specs/web-apps/current-work/#the-canvas-element
Attachment #437600 - Flags: review?(Olli.Pettay) → review+
Comment on attachment 437600 [details] [diff] [review]
Patch v1

Yes! I asked for this not to be put in when I originally reviewed this code IIRC.
Attachment #437600 - Flags: superreview+
(Assignee)

Comment 4

8 years ago
Created attachment 437813 [details] [diff] [review]
Patch v2

> Could you have style="background: black;" here and elsewhere.

Done. Thanks!
Attachment #437600 - Attachment is obsolete: true
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/b6f9d648a242
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite+
Keywords: checkin-needed
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Duplicate of this bug: 291372
You need to log in before you can comment on or make changes to this bug.