If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

GetFolder: Crash when "Current User" is target folder

VERIFIED WORKSFORME

Status

Core Graveyard
Installer: XPInstall Engine
P2
critical
VERIFIED WORKSFORME
19 years ago
2 years ago

People

(Reporter: Jimmy Lee, Assigned: dougt)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Build: 4/9/99 Engineering build

1. Go to http://jimbob/jars and click on an8bitscript_currentuser.jar

f = Install.GetFolder("Current User", "charset");

RESULT:
Crash.  Log file shows no jar activity.

EXPECTED RESULT:
A folder named "charset" is created and populated with files as described from
install script.  There are some target folders that work fine.
(Reporter)

Updated

19 years ago
Priority: P3 → P2
QA Contact: 4395 → 4138
(Reporter)

Comment 1

19 years ago
Changing QA Contact from Grace to Jimmy.

Updated

19 years ago
Target Milestone: M8
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

19 years ago
I have fixed the Current Usertarget of GetFolder().  However, the jar still
crashes due to bug 6661.  I have modified the jar to work around this problem
which verifies that this bug is fixed.  You can find this modified jar here:

http://grok/u/dougt/xpinstall/an8bitscript_currentuser_mod.jar
(Reporter)

Comment 3

19 years ago
Build 6/1/99 Windows

I am reopening this report to inquire why the modified jar fails while the
unmodified one is now successful.

I'm crashing immediately when triggering the modified jar.  However, unlike bug
http://bugzilla.mozilla.org/show_bug.cgi?id=5577, triggering the unmodified jar
now behaves as expected.  The Install.log shows that the jar was triggered
succesfully.
Status: RESOLVED → REOPENED

Updated

19 years ago
Resolution: FIXED → ---

Comment 4

19 years ago
Clearing Fixed resolution.

Updated

19 years ago
Target Milestone: M8 → M10

Comment 5

19 years ago
setting target milestone to M10

Jimmy please verify if this is still an valid bug
(Reporter)

Comment 6

19 years ago
Build 6/16/99 SeaMonkey
1. Go to http://puma/xpinstall/test/trigger.html (Samir's trigger--mine doesn't
   work) and trigger
   http://grok/u/dougt/xpinstall/an8bitscript_currentuser_mod.jar

I still get a crash on Windows NT. However, a "charset" folder is created as
expected and files are added up to "ch170-?".

Talkback Incident ID = TB10115022Q

Call Stack: (Signature = 0x0012fe80 fc18e85d)

0x0012fe80
0x00720072
0x02000003
(Assignee)

Updated

18 years ago
Status: REOPENED → ASSIGNED
Depends on: 10098
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

18 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 7

18 years ago
Build 7/30/99

This still crashes for me with an8bitscript_currentuser_mod.jar.  The folder is
created and some files are added.  This time it got as far as ch204-Þ.  Linux
and Macintosh behave fine.  The problem is only with WindowsNT and Win98.  Win95
has not been tested yet.

Talkback Incident ID = 11924298
Call Stack: (Signature = 0x0012fe6c 17a3bc81)
0x0012fe6c

http://cyclone/reports/incidenttemplate.CFM?reportID=124&style=0&tc=8&cp=1&ck1=S
User+email+address&cd1=%25jimmylee%40netscape%2Ecom%25&co1=like&bbid=11924298

Updated

18 years ago
Resolution: WORKSFORME → ---

Comment 8

18 years ago
Clearing WorksForMe resolution due to reopen.
(Assignee)

Updated

18 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 9

18 years ago
okay.  I can not reproduce this again.  Lets do the basic problem thing and
break this bug into pieces.

First, lets remove all the 8 bit characters from this jar file.  Let make a
simple case that does an add of 1000 files into current user.

Second, lets make a test case that only adds 8bit files.

Third, lets get together so that you can show me the crash.  I maybe able to
figure out more than the talkback report.

Until then, I will leave as assigned.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 10

18 years ago
After talking to cathleen, she comfirms that the problem really is the 8bit
characters.  This 8 bit problem, only occurs on optimized builds.  I am closing
*this* bug as WORKS_FOR_ME and advise opening a new bug regarding the 8bit
characters.
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

18 years ago
Marking this verified.  Will investigate 8-bit characters further and enter new
bug if necessary.

Comment 12

18 years ago
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.