Adjust font and icon sizes in the new add-ons manager

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [AddonsRewrite])

Attachments

(3 attachments)

Right now the font and icon sizes in the left pane are too big and doesn't fit into the overall style. Even when we have a whole tab now, shouldn't we use the same sizes as we have in all the other dialogs and sidebars, e.g. the bookmarks sidebar?

Adding ui-wanted to get feedback from the ux team.
Agreed! It's the first thing that jumped out at me when I fired up a test build.
Note that we don't actually have an overall style yet - with the theme changes, and moving things like the addons manager into content, the style used here is temporary.

But FWIW, I like that the items in the left pane are bigger. I'm not sure what we'd gain by making them small; it's not going to be a long list of items like the bookmarks sidebar.
Duplicate of this bug: 562896
Blocks: 567714
Whiteboard: [AddonsRewrite]

Comment 4

9 years ago
The addon manager I have to say is far too bloated visually by default. Although, after some bug trawling I have made a few discoveries, most important of which is this old old bug for about:config dated 2003, requesting support for things to be resized with Ctrl-Scroll.

https://bugzilla.mozilla.org/show_bug.cgi?id=208088

Seems you can change the size of the page with Ctrl-+ and Ctrl-- , and having done this, I am now much happier. 

However, there really should be some more obvious way of changing this. 

( Especially as the aforementioned trick doesn't work on the download manager, and I'm stuck with this giant monster )

https://bugzilla.mozilla.org/show_bug.cgi?id=391910

Similar bug from 2008 about how addon manager and download manager have some inconsitencies between the 2. ( Back before Addon-manager became a tab )

Comment 5

8 years ago
(In reply to comment #0)
> Right now the font and icon sizes in the left pane are too big ... <Snip>

(In reply to comment #3)
> *** Bug 562896 has been marked as a duplicate of this bug. ***

This bug report just mentions font size in the left pane, and mainly about the overall style of the Add-Ons Manager. Bug 562896 was about the font size of all the text in the Add-Ons Manager, which at the default size is so big that information doesn't comfortably fit into it in some Windows that aren't maximized (but still quite reasonably sized for normal browsing).

Are these really the same issue? It would be possible to keep the same overall design, and retaining how much bigger proportionally the font in the left pane is from that elsewhere, while fixing the issue of content not fitting, by reducing the base font size a notch or too (equivalent to pressing Ctrl+Minus once or twice). (Conversely, a new visual design and making the left pane's font and icons smaller may do nothing to fix the content-not-fitting issue.)
I've attached a mockup of the intended sizes and weights for text in the add-ons manager in Windows and OSX.

Blair is right in Comment 2 that the current style is unfinished.  The mockup attached is what we're working to now.  

Henrik and Brian King, do you feel your concerns are addressed sufficiently if we implement this mock?
(In reply to comment #7)
> Henrik and Brian King, do you feel your concerns are addressed sufficiently if
> we implement this mock?

I've gotten used to the current design and it doesn't hurt as much as it did in comment 1. In saying that, I think this mockup looks great. The smaller text and un-bolding of the category names really makes the add-on names themselves stand out more -- which they should.
With all the last iterations of the Add-ons Manager UI it looks quite perfect in the Firefox 4 release when talking about fonts and icon sizes. There is still room for improvements which your mockup covers nicely. So I can second Brian.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: uiwanted
Resolution: --- → FIXED

Comment 10

7 years ago
How has this been fixed? I've just downloaded the latest beta, and the problem still seems to exist: the text in the add-ons manager (particularly the menu down the left and the extensions' names) is massively larger than any other text anywhere else on my screen, in Firefox or any other app, and it's pushing content off the right of my window, causing a horizontal scrollbar to appear.
(In reply to Smylers from comment #10)
> How has this been fixed?

In the Sense of the Reporter it has been fixed as it seems.
Thus, if you like to raise Issues in Addition please file a new separate Report and attach your Screenshot there.
You need to log in before you can comment on or make changes to this bug.