Closed Bug 558005 Opened 11 years ago Closed 10 years ago

Better 'dead' instance handling

Categories

(Firefox :: General, enhancement)

3.6 Branch
x86
Windows 7
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 452770

People

(Reporter: Neo_In_Matrix, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

Sometimes FF quits slowly and I try to start it again, then FF shows a message box that says something like 'Another instance is running'. So I have to close the box and wait for several seconds and start FF again.

This can be improved in some way. Say, show a progress dialog that waits the old instance until it fully quits and automatically start a new instance; and have a timeout after which the dialog could forcibly kill the old one.

Reproducible: Sometimes
Usually this is caused by an extension. Try safe mode or a new profile to see.
http://support.mozilla.com/en-US/kb/Safe+mode
It's not a bug actually, though I used the word 'dead'. That's why I classified this problem as 'enhancement'.

I mean you can display a progress dialog that waits for the running instance to quit and re-start.
Duplicate of Toolkit bug 452770 -> Toolkit bug 286355?
Version: unspecified → 3.6 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 452770
You need to log in before you can comment on or make changes to this bug.