Add-on installation notification bar also appears for whitelisted websites

VERIFIED FIXED

Status

()

VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rewrite])

(Reporter)

Description

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a4pre) Gecko/20100407 Minefield/3.7a4pre (.NET CLR 3.5.30729)

Even when a page has been whitelisted for add-on installation the notification bar appears each time I want to install an extension.

Steps:
1. Create a fresh profile and check that addons.mozilla.org is whitelisted
2. Go to https://addons.mozilla.org/en-US/firefox/addon/6622
3. Install the extension

I don't expect to see the yellow notification bar because the website has been whitelisted.
I'm not seeing this. I take it in step 1 you went to the preferences and verified addons.mozilla.org and getpersonas.com were both in the exceptions list?
(Reporter)

Comment 2

9 years ago
Correct. AMO was whitelisted inside the preferences. Right now I cannot reproduce but I will try to get a screencast and hopefully some steps to reproduce when it occurs the next time.
Is it possible you cleared the profile after checking the whitelist at all? I currently know about bug 553092 where trying to install from AMO without going into preferences first would not properly initialise the whitelist and so see the notification bar.
(Reporter)

Comment 4

9 years ago
Hah, that's it! I was wrong with my step 1 so discard it. After starting the new profile directly install an extension and the notification bar opens. I will add the dependency to bug 553092.
Depends on: 553092
So this is just fixed by bug 553092 right?
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

8 years ago
Yeah, doesn't happen anymore with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a5pre) Gecko/20100518 Minefield/3.7a5pre

So which type of tests do we need? Do we already have automated tests or is a manual test necessary here?
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
Flags: in-litmus?
I believe that this is covered by the browser_whitelist* tests
Flags: in-testsuite?
Flags: in-testsuite+
Flags: in-litmus?
Flags: in-litmus-
You need to log in before you can comment on or make changes to this bug.