Closed Bug 558070 Opened 14 years ago Closed 14 years ago

[OOPP] Flash debug player appears as crashed when debugging with a breakpoint during initialisation

Categories

(Core Graveyard :: Plug-ins, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: andrew, Unassigned)

References

Details

(Whiteboard: [OOPPTestday])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a3) Gecko/20100315 MozillaDeveloperPreview/3.7a3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a3) Gecko/20100315 MozillaDeveloperPreview/3.7a3 (.NET CLR 3.5.30729)

I'm using Flex Builder to develop flash applications.  If I run my application in the debugger with a breakpoint in the application startup (that is, before the loading screen has been removed) then when the debugger hits the breakpoint, if I don't restart it within a couple of seconds, Firefox reports that flash has crashed.

If the application is allowed to initialise fully then I can sit in the debugger for as long as I like; as in previous versions of Firefox, the browser is non-responsive while the debugger is paused.

Reproducible: Always

Steps to Reproduce:
1. Run a flex application under the flex debugger, with a breakpoint in application startup.
2. Don't re-start the debugger when it hits the breakpoint.
3.
Actual Results:  
Firefox reports that flash has crashed, the debugger is disconnected.

Expected Results:  
Firefox should have remained unresponsive until the debugger was resumed.
Blocks: OOPP
Whiteboard: [OOPPTestday]
Status: UNCONFIRMED → NEW
Component: General → Plug-ins
Ever confirmed: true
QA Contact: general → plugins
Turning off the hang detector may help - open about:config and set 'dom.ipc.plugins.timeoutSecs' to a high value.
This is by design. You can disable the hang detector by setting dom.ipc.plugins.timeoutSecs to -1
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WONTFIX
Benjamin, once the Flash application has initialised, I'm able to sit in the debugger for as long as I need to -- it's only while the Flash application's starting up that I have problems.  It's the inconsistency that led me to think that maybe it would be possible for the debugger to work during Flash application initialisation.
Is it possible to disable hang detector on a domain- or wildcard-basis? I am also developing Flex apps and rely on the debug version of Flash 10. I wouldn't want to disable this feature for all sites, but I also can't have Firefox hang if I'm slow responding to a debug alert.
No, it is not.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.