Browser crashes when saving file.

VERIFIED DUPLICATE of bug 57326

Status

()

Core
Networking
P3
critical
VERIFIED DUPLICATE of bug 57326
18 years ago
18 years ago

People

(Reporter: kinmoz, Assigned: neeti)

Tracking

({crash, regression})

Trunk
x86
Windows NT
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood-] [rtm-], URL)

(Reporter)

Description

18 years ago
Using my 10/08/00 Win32 Netscape_20000922_BRANCH Mozilla debug build ...

If I load the following URL into my browser window:

    http://bugzilla.mozilla.org/showattachment.cgi?attach_id=16222

Then select 'File->Save As' from the menu, I get an assertion in 
AsyncReadStreamAdaptor::Cancel() because mEventQueueStreamListener is null.

If I continue past the assertion, I crash.

Here's the stack trace to the assertion I'm getting:


NTDLL! 77f762e8()
nsDebug::Assertion(const char * 0x01dd3454 
??_C@_0DJ@KMGL@You?5can?8t?5dereference?5a?5NULL?5nsC@, const char * 0x01dd3498 
??_C@_0N@NHHF@mRawPtr?5?$CB?$DN?50?$AA@, const char * 0x01dd39dc 
??_C@_0CB@MCGB@?4?4?2?4?4?2?4?4?2dist?2include?2nsCOMPtr?4h@, int 649) line 256 
+ 13 bytes
nsDebug::PreCondition(const char * 0x01dd3454 
??_C@_0DJ@KMGL@You?5can?8t?5dereference?5a?5NULL?5nsC@, const char * 0x01dd3498 
??_C@_0N@NHHF@mRawPtr?5?$CB?$DN?50?$AA@, const char * 0x01dd39dc 
??_C@_0CB@MCGB@?4?4?2?4?4?2?4?4?2dist?2include?2nsCOMPtr?4h@, int 649) line 396 
+ 21 bytes
nsCOMPtr<nsIStreamListener>::operator->() line 649 + 34 bytes
AsyncReadStreamAdaptor::Cancel(unsigned int 2153185313) line 78 + 36 bytes
nsMemCacheChannel::Cancel(nsMemCacheChannel * const 0x06568310, unsigned int 
2153185313) line 429
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x066df410) line 107 + 22 bytes
PL_HandleEvent(PLEvent * 0x066df410) line 580 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00abf2e0) line 513 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x1a6c0274, unsigned int 49341, unsigned int 0, 
long 11268832) line 1049 + 9 bytes
USER32! 77e7124c()
00abf2e0()
(Reporter)

Comment 1

18 years ago
Adding keywords: rtm, regression, dogfood, crash
Keywords: crash, dogfood, regression, rtm

Comment 2

18 years ago
neeti: the stack suggests a dup of your cache crashers. I do not believe that 
its crashing for ALL download's and so am making this a dogfood- but we should 
consider its severity for rtm.
Assignee: gagan → neeti
Whiteboard: [dogfood-]
(Assignee)

Comment 3

18 years ago
I am not able to reproduce this crash.
(Assignee)

Comment 4

18 years ago
Kin,

I am not able to reproduce this crash. I notice that the stack trace attached 
has nsMemCacheChannel in it. If we load the browser, with the default settings 
for cache in the prefs panel, we should be using the disk cache, and not hitting 
the memory cache at all. What are your settings in the prefs panel for the 
cache, when you get this crash?

Thanks,
Neeti
(Reporter)

Comment 5

18 years ago
I'm still seeing this crash with my Netscape_20000922_BRANCH debug build on 
Win32.

My prefs are set as follows:

    Memory Cache: 1024 KBytes
    Disk Cache:   7680 KBytes
    Compare the page in the cache to the page on the network:  "Once per 
session"
(Reporter)

Comment 6

18 years ago
I doubt this matters, but I'm connected to Netscape via a 37,300 bps modem 
connection running SERA.
(Assignee)

Comment 7

18 years ago
I am still not able to reproduce this with the latest branch build. Tever, can 
you help me in reproducing the crash?

Thanks,
Neeti
(Assignee)

Comment 8

18 years ago
kin,

Do you crash, if you start with a clean cache directory?

Thanks,
Neeti
(Reporter)

Comment 9

18 years ago
I'll give it a try ... the crash is happening on my home machine, and I'm not
seeing the crash here at Netscape.

Comment 10

18 years ago
smaller visibility, hard to track => rtm-
Whiteboard: [dogfood-] → [dogfood-] [rtm-]
(Assignee)

Comment 11

18 years ago
I am marking this bug as duplicate of bug 57326

*** This bug has been marked as a duplicate of 57326 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 12

18 years ago
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.