random end-of-line font changes

RESOLVED DUPLICATE of bug 250539

Status

Thunderbird
Message Compose Window
--
minor
RESOLVED DUPLICATE of bug 250539
7 years ago
7 years ago

People

(Reporter: mark huss, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1 Thunderbird/3.0.4

This may be related to 250539.

If you in HTML WYSIWIG mode and are replying to an e-mail with the original below (i.e., normal configuration) and go backwards in the current line to edit it, then hit End to resume typing, the font changes to that of the following included text. (This assumes the font is different, which it usually is in my setup).


	



Reproducible: Always

Steps to Reproduce:
1.Respond to an e-mail in HTML format
2.Type a word, hit Home, then End. Start typing, font has changed.
or
2. type a word, hit right arrow (takes you to next line) then up arrow (takes you to end of previous line), font has changed.
Actual Results:  
The font changes unexpectedly, giving your response that 'computer illiterate' look.

Expected Results:  
The font should stay the same on the current line unless you explicitly change it.

There should be an implied newline at the end of the line you're typing to keep the following line font separated.

The annoying workaround is to 'split the previous word' by hitting enter, and then retyping the text you entered in the wrong font, then deleting the extra garbage text.

This one of those really annoying, over and over again bugs I fight with every day. 

Another workaround is to set the default and composition fonts to all the same face and size.
(In reply to comment #0)
> This may be related to 250539.

I believe that's correct, so I'll resolve duplicate accordingly. Thanks for the careful description; it may turn out that one of the duplicates needs to be reopened to separate end-of-line from new-paragraph issues, in which case this is a likely candidate, IMO.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 250539
You need to log in before you can comment on or make changes to this bug.