If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bookmarks Toolbar Doesn't Fit New Theme, Should Be Vertical Auto-Hide Slidebar

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
8 years ago
7 years ago

People

(Reporter: Paul [pwd], Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

The new theme has been designed for tabs on top and very little going on, thus features like the bookmarks toolbar don't actually fit. My idea is to have it as a side bar that's automatically hidden bar when you hover over a specific area.

Reproducible: Always

Updated

8 years ago
Component: Theme → Bookmarks & History
QA Contact: theme → bookmarks

Comment 1

8 years ago
Related to/duplicate of bug 380566?
(Reporter)

Comment 2

8 years ago
Not exactly. This would essentially be the Jetpack Slidebar but rather than populated with Jetpacks, it would be populated with bookmarks.

Picture of sidebar in case you haven't seen it: http://i43.tinypic.com/28qzz1d.jpg

Here's a video: http://vimeo.com/5102695

If you substitute where he opens up the wiki article with a live bookmark list (rss feed), it's replicate the functionality I'm talking about exactly.
Bookmarks sidebar already exists... you just have to hide the toolbar and use CTRL+B instead...
(Reporter)

Comment 4

8 years ago
Bookmarks sidebar is fundamentally different. Bookmarks sidebar is a huge list of bookmarks in hierarchical format. What I'm talking about is making the Bookmarks Toolbar into a sidebar. Think of it as the difference between viewing the Windows 7 taskbar through explorer and as intended (globally at the bottom/top/sides of the screen).

When you look at the mock-ups and use the latest alphas for 3.7 there is a hierarchical order to the design (tabs -> control -> page). The bookmarks toolbar doesn't fit that because it was (or at least seems as though it was) part of the design after-though which was space-reduction-centric. As such I feel that it should be separated completely and made into an icon bar from the side of the screen that displays at the bookmarks toolbar does.

If users then want to open up the bookmarks sidebar, then of course, they can do that, but this doesn't idea doesn't replicate that functionality.

I apologise for how bad a job I'm doing at explaining this, but assure you that the bookmarks sidebar and this proposed "bookmarks slidebar" are like night and day.
(Reporter)

Updated

8 years ago
Summary: Bookmarks Toolbar Doesn't Fit New Theme, Should Be Vertical Auto-Hide Sidebar → Bookmarks Toolbar Doesn't Fit New Theme, Should Be Vertical Auto-Hide Slidebar
(Reporter)

Comment 5

8 years ago
Changed title from sidebar -> slidebar to help ease confusion.
I do not think that we are going to make this part of the standard Firefox build at this time. It can continue to be an extension.

The UX team is currently working through their plans for the bookmarks toolbar in the new theme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
We are planning on having an icon on the main toolbar that will produce a bookmarks panel.  Not exactly what you are asking for, but it does hves the same transient nature as an auto-hide slidebar.
(Reporter)

Comment 8

8 years ago
That sounds really good. Hopefully it'll be icon-orientated rather than text-orientated. I believe Microsoft as were Apple were onto something with their move away from text labels on the Task Bar. I'm eager to see the evolution of the quick bookmarks idea.
(Reporter)

Updated

7 years ago
OS: Windows 7 → All
Hardware: x86 → All
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.