Closed Bug 558146 Opened 11 years ago Closed 11 years ago

Missing/Damaged mozilla-runtime causes hang

Categories

(Core :: Plug-ins, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 535077

People

(Reporter: andreasjunghw, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100408 Minefield/3.7a5pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100408 Minefield/3.7a5pre

If mozilla-runtime.exe is missing or damaged Minefield hangs as soon as it tries to run it (see also bug 522190 comment 5).

It should instead recognize that running mozilla-runtime.exe failed and prompt the user with a dialog (or reuse the plug-in crashed UI?) that it was not possible to run mozilla-runtime.exe and what the user can do to fix the problem.

Reproducible: Always

Steps to Reproduce:
1. close Minefield
2. rename mozilla-runtime.exe
3. start Minefield
4. visit a page that requires a plug-in
Actual Results:  
Minefield hangs.

Expected Results:  
Minefield should not hang and tell the user that mozilla-runtime couldn't be run.
No longer blocks: OOPP
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 535077
Blocks: OOPP
Andreas, I'm interested in knowing how you ended up with a missing/damaged mozilla-runtime.
Therefore I wrote "see bug 522190 comment 5", because I have written there how I ended up with a 0-byte mozilla-runtime.exe

Short: The partial update failed and damaged the file.
I don't have a clue why...
You need to log in before you can comment on or make changes to this bug.