Closed Bug 558173 Opened 10 years ago Closed 10 years ago

closing tab with flash causing crash [@ mozilla::plugins::PStreamNotifyParent::Send__delete__(mozilla::plugins::PStreamNotifyParent*, short const&) ]

Categories

(Core :: Plug-ins, defect, critical)

x86_64
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 558130

People

(Reporter: HawanTB, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; pl; rv:1.9.3a5pre) Gecko/20100408 Minefield/3.7a5pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; pl; rv:1.9.3a5pre) Gecko/20100408 Minefield/3.7a5pre (.NET CLR 3.5.30729)

Firefox 3.7a5 crash if I have opened few tabs and one or more is flash, and then I close tab with flash

Reproducible: Always

Steps to Reproduce:
1. open few different tabs
2. open one or more tabs with Flash content (flash movie)
3. close tab with flash content
Actual Results:  
Firefox crashed

Expected Results:  
closing tab with flash content
blocking2.0: --- → ?
What version of Flash? Any crash reports? http://support.mozilla.com/en-US/kb/Mozilla+Crash+Reporter
blocking2.0: ? → ---
Component: Extension Compatibility → Flash (Adobe)
Product: Firefox → Plugins
QA Contact: extension.compatibility → adobe-flash
I have always up to date flash version (10.0.45.2)
example (one from few sent) crash stats :
http://crash-stats.mozilla.com/report/index/02f16147-9858-41c6-af2f-5976f2100408
Component: Flash (Adobe) → Extension Compatibility
Product: Plugins → Firefox
Version: unspecified → Trunk
Component: Extension Compatibility → Flash (Adobe)
Product: Firefox → Plugins
Version: Trunk → unspecified
In about:config does setting dom.ipc.plugins.enabled to false stop the crashing?
Yes, setting dom.ipc.plugins.enabled to false stopped crashing
Component: Flash (Adobe) → IPC
Product: Plugins → Core
QA Contact: adobe-flash → ipc
Summary: closing tab with flash causing crash → closing tab with flash causing crash [@ mozilla::plugins::PStreamNotifyParent::Send__delete__(mozilla::plugins::PStreamNotifyParent*, short const&) ]
Version: unspecified → Trunk
Component: IPC → Plug-ins
QA Contact: ipc → plugins
Do you have adblock plus? This is probably a dup of bug 558130
Status: UNCONFIRMED → NEW
Ever confirmed: true
He does http://crash-stats.mozilla.com/report/index/02f16147-9858-41c6-af2f-5976f2100408#extensions
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 558130
You need to log in before you can comment on or make changes to this bug.