If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Encryption defaults not used when switching 'From' accounts

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Michel Meyers, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a4pre) Gecko/20100406 Minefield/3.7a4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1 Thunderbird/3.0.4

I have two accounts defined in TB, one (account A) with x509 certificates, which is set to not encrypt and not sign e-mails by default, and one (account B) that has no such certificates associated to it. When I compose an e-mail on account B and change the 'From' from account B to account A using the drop down box, the options to encrypt and sign the e-mail automatically get enabled for that e-mail.

Reproducible: Always

Steps to Reproduce:
1. Create 2 accounts, one with x509 certificates associated to it, one without.
2. Set first account to not encrypt/sign by default.
3. Compose e-mail using second account (or use reply/forward).
4. Change the 'From' from second account to first account.
Actual Results:  
Both the sign and encrypt option are enabled for the outgoing mail.

Expected Results:  
Sign and encrypt options should be set according to the defaults specified in the new 'From' account's options.

Not sure if this might be relevant, but I do have the Enigmail plugin installed.
Have you tried safe mode? (see https://support.mozillamessaging.com/en-US/kb/Safe+Mode for more information)

Are these two accounts are two identities on the same account ?
And I don't have the issue with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.4pre) Gecko/20100411 Lanikai/3.1b2pre
(Reporter)

Comment 3

8 years ago
These are two separate accounts.

I tried Safe Mode and was not able to reproduce the issue there. Strangely enough, I was also no longer able to reproduce the issue after going back to normal mode.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.