Remove duplication between `users` and `auth_user`

RESOLVED FIXED in 4.x (triaged)

Status

addons.mozilla.org Graveyard
Code Quality
P3
normal
RESOLVED FIXED
8 years ago
2 years ago

People

(Reporter: clouserw, Assigned: ashort)

Tracking

unspecified
4.x (triaged)

Details

(Whiteboard: [qa-])

(Reporter)

Description

8 years ago
These two tables have a bunch of duplicate data and aside from being more confusing it affects how we handle users.  For example, when logging in we check for users.deleted but not django's auth_user.is_active.
(Reporter)

Updated

4 years ago
Assignee: nobody → ashort
(Assignee)

Comment 1

4 years ago
https://github.com/mozilla/olympia/commit/3df883d09bb352fc5e2d4883b7b3b024af7d95be
https://github.com/mozilla/zamboni/commit/60316d3c3a4a0365b1527382199acaa0c51091cd
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [qa-]

Updated

4 years ago
Duplicate of this bug: 876525
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.