Status

()

Core
Plug-ins
RESOLVED INCOMPLETE
8 years ago
4 years ago

People

(Reporter: Henry, Unassigned)

Tracking

1.9.2 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.4pre) Gecko/20100410 Ubuntu/9.10 (karmic) Namoroka/3.6.4pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.4pre) Gecko/20100410 Ubuntu/9.10 (karmic) Namoroka/3.6.4pre

Whenever you navigate to any page containing flash, Firefox gets hung. The only action possible is to kill Firefox by means of the System Activity or by pressing the close X button. 

Reproducible: Always

Steps to Reproduce:
1. Navigate to any site containing Flash
2. FF starts to download the page
3. when flash is requested, FF hangs.
Actual Results:  
Firefox hangs  every time.

Expected Results:  
Flash is played.
what version of flash player do you have?
(Reporter)

Comment 2

8 years ago
    Filename libflashplayer.so
    Plugin Version: 
    Plugin Description: Shockwave Flash 10.0 r45
Does it never restore?
(Reporter)

Comment 4

8 years ago
No! It simply hangs. No button are click-able, nor link, nor tab, but the "X" close button.
When looking on the System Activity, the FF process is working. Sympli, it does not respond to any click or keyboard command.

Comment 5

8 years ago
same here. i'm using namoroka version 3.6.4~hg20100410r34032+nobinonly-0ubuntu1~umd1~karmic on amd64 with just updated flash 10.0 r45

as said, it simply hangs: cpu at 0%, it's just locked

Comment 6

8 years ago
(In reply to comment #5)

I've also tried 3.7 version "minefield", but same behaviour

Comment 7

8 years ago
just discovered the problem is related to the latest OOPP (out of process plugin)

entering about:config and modifying the key dom.ipc.plugins.enabled.libflashplayer.so to false, fixes the problem
(Reporter)

Comment 8

8 years ago
Great job!
This solves the problem for me. Thanks!
The issue is now marked as solved although, I have a question: could you please tell what the record dom.ipc.plugins.enabled.libflashplayer.so relates to?

Thanks again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
that is oopp, so this is still a bug.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 10

8 years ago
I have filed a bug (581302) which might be related to this one. Also the following may be connected: 558555, 580497, 579597, 581302.

My observations on my low-end hardware PCs are that Flash content web pages cause high CPU usage. This effect was quite dramatically increased after the landing of 'Retained Layers' on Trunk.  The effect is further compounded if OOPP is activated for the Flash plugin.

Several bugs have attributed the cause of 'slow scrolling' and 'hanging' to OOPP implementation, the flash plugin itself or 'retained layers' but in my experience they seem to be closely related.

Updated

7 years ago
Version: unspecified → 3.6 Branch
See also: https://bugzilla.mozilla.org/show_bug.cgi?id=713367#c3

I've been experiencing choppy performance on OS X nightly, particularly with flash content.

Comment 12

6 years ago
Does it still exist with Firefox 11+ and Flash Player 11.2.202.233+ ?
Try it with en-/disabled Flash Player hardware acceleration please.
Check/update your graphics driver and OS too.

Updated

4 years ago
Component: General → Plug-ins
Product: Firefox → Core
Version: 3.6 Branch → 1.9.2 Branch

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago4 years ago
Resolution: --- → INCOMPLETE

Comment 13

4 years ago
https://crash-stats.mozilla.com/report/index/ef720bd4-0f3c-4a82-ae44-e6c7e2131121
You need to log in before you can comment on or make changes to this bug.