navigator.geolocation.getCurrentPosition(function(coords){}) fails

RESOLVED DUPLICATE of bug 517510

Status

()

RESOLVED DUPLICATE of bug 517510
9 years ago
9 years ago

People

(Reporter: real.sergeych, Unassigned)

Tracking

1.9.2 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_3; en-US) AppleWebKit/533.2 (KHTML, like Gecko) Chrome/5.0.342.9 Safari/533.2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; ru; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

location is undefined
[Break on this error] this.coords = new WifiGeoCoordsObject(location.latitude,\n

Reproducible: Always

Steps to Reproduce:
1.execute JS code above
2.check js console

Actual Results:  
error report: location is undefined
[Break on this error] this.coords = new WifiGeoCoordsObject(location.latitude,\n

Expected Results:  
no errors

It worked just with previous release
Component: General → Geolocation
Product: Firefox → Core
QA Contact: general → geolocation
Version: unspecified → 1.9.2 Branch
Duplicate of this bug: 558681
er, i meant bug 517510, and yes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 517510
You need to log in before you can comment on or make changes to this bug.