Lower side of table's cell doesn't react to mouseover when rowspan is used for table's cell and when table caption tag is used.

RESOLVED DUPLICATE of bug 604270

Status

()

RESOLVED DUPLICATE of bug 604270
9 years ago
7 years ago

People

(Reporter: kuzumi, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; ja; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; ja; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

Lower side of table's cell doesn't react to mouseover when rowspan is used for table's cell and when table caption tag is used.

<style type="text/css">
table{
width:500px;
border:1px solid #ccc;
}
th,td{
height:3em;
border:1px solid #ccc;
}
th:hover,td:hover{
border:1px solid #f00;
}
</style>

<table>
<caption>CAPTION TEXT</caption>
<tr>
<th rowspan="2">This cell's under area is can't mouseover.</th>
<td>&nbsp;</td>
</tr>
<tr>
<td>&nbsp;</td>
</tr>
</table>

Reproducible: Always

Steps to Reproduce:
1.Html is displayed with Firefox 3.6.3.
2.Mouseover on lower side of cell that uses rowspan. 
Actual Results:  
This happens only when table caption tag is used.

Expected Results:  
OS: Windows XP, Windows 7
browser: Firefox 3.6.3
*I.E.6.0, I.E.7.0, I.E.8.0, Chrome4.0 is not happen.
*It doesn't have Firefox of old version.
html: html4.01,xhtml1.0 and CSS2

Demo
http://www.kuzumi.net/bug/table_caption_rowspan.html

Reference
* 11.2.2 Table Captions: The CAPTION element
http://www.w3.org/TR/html401/struct/tables.html#edef-CAPTION
* 11.2.6 Table cells: The TH and TD elements
http://www.w3.org/TR/html401/struct/tables.html#h-11.2.6
* 5.11.3 The dynamic pseudo-classes: :hover, :active, and :focus
http://www.w3.org/TR/CSS2/selector.html#dynamic-pseudo-classes

thanks
(Reporter)

Comment 1

9 years ago
Mouseover is reactive to next line's tr-block when confirming it with Firebug Add-on.
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a5pre) Gecko/20100410 Minefield/3.7a5pre

This worked fine with the latest Firefox 2.0, but not with latest 3.0.
Component: General → Layout: Tables
Product: Firefox → Core
QA Contact: general → layout.tables
Version: unspecified → Trunk
(Reporter)

Comment 3

9 years ago
In W3C, description of behavior of hover of each element was not found.

>>This worked fine with the latest Firefox 2.0, but not with latest 3.0.

Thanks for help info.
(Reporter)

Updated

9 years ago
Component: Layout: Tables → General
Product: Core → Firefox
Component: General → Layout: Tables
Product: Firefox → Core
(Reporter)

Comment 4

9 years ago
This worked not fine with latest Firefox 3.6.7.
Marking duplicate of a later bug with more data....
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 604270
You need to log in before you can comment on or make changes to this bug.