Port Bug 524745 [Session restore sets focus to minimized windows] to SeaMonkey

RESOLVED FIXED in seamonkey2.1a1

Status

SeaMonkey
Session Restore
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Misak Khachatryan, Assigned: Misak Khachatryan)

Tracking

Trunk
seamonkey2.1a1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

7.57 KB, patch
neil@parkwaycc.co.uk
: review+
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

7 years ago
From parent bug:

STR:
1. Have Firefox remember your tabs from last time at startup.
2. Minimize a window.
3. Close the browser without activating the window (right click taskbar entry,
close)
4. Start the browser up
5. Window displays, minimizes and then restores.

[depends on the patch in bug 520178]

This is a spin off from bug 520178. On windows, this problem is hidden by
another bug where session store didn't know the correct size mode of windows.

Once the patch in 520178 lands, this bug will be exposed.

Stepping through with venkman, this focus call is the cause -

http://mxr.mozilla.org/mozilla-central/source/browser/components/sessionstore/src/nsSessionStore.js#2440
(Assignee)

Comment 1

7 years ago
Created attachment 438334 [details] [diff] [review]
patch plus test

I also removed spaces in Makefile and replaced them with one tab, as Serge ask in https://bugzilla.mozilla.org/show_bug.cgi?id=480109#c20

I ran test on my Fedora 12, no failed test seen.
Attachment #438334 - Flags: superreview?(neil)
Attachment #438334 - Flags: review?(neil)

Updated

7 years ago
Attachment #438334 - Flags: superreview?(neil)
Attachment #438334 - Flags: superreview+
Attachment #438334 - Flags: review?(neil)
Attachment #438334 - Flags: review+
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
(Assignee)

Comment 2

7 years ago
Pushed http://hg.mozilla.org/comm-central/rev/4703fed91fcf
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Target Milestone: --- → seamonkey2.1a1
You need to log in before you can comment on or make changes to this bug.