I updated to Firefox 3.5.9 recently, and now Firefox crashes multiple times every day. [@ free | js_json_stringify(JSContext*, unsigned int, int*) ]

VERIFIED DUPLICATE of bug 553514

Status

()

Firefox
General
--
major
VERIFIED DUPLICATE of bug 553514
8 years ago
7 years ago

People

(Reporter: joanne613, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sg:dupe 553514])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; GTB6.4; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; MDDS; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; OfficeLiveConnector.1.3; OfficeLivePatch.0.0)
Build Identifier: 3.5.9

I had updated my work computer to FFx 3.6 and disliked losing so many add-ins, so I only updated my home computer to 3.5.9 instead.  Since updating my home computer to 3.5.9 about a week or so ago, my browser has been crashing several times every day, sometimes before the browser completely reloads.  I do not know if this is related to any particular site opened in my tabs, and I have sent the "crash report" as FFx Crash Reporter allows every time, but I have not heard back at all.

Reproducible: Always

Steps to Reproduce:
1. No steps necessary to cause the crash, it just happens every single time; time frame ranges from before all tabs have even loaded, to an hour or two into browsing.

Actual Results:  
It crashes every time.

Expected Results:  
It crashes every time.

It should not crash -- supposedly 3.5.9 is the most stable build at this point, but that is not my experience.  My previous installations of 3.5.0 and 3.5.2, while not as feature-rich, were more stable and crashed at most once or twice a month, even under heavy usage.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.5 Branch
https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report
(Reporter)

Comment 2

8 years ago
crash reports:
Report ID                                  	Date Submitted
bp-934cd7cc-a011-4fed-9146-5b2352100411	4/11/2010	11:07 PM
bp-8db31459-8314-47e3-b487-632c72100411	4/11/2010	6:14 PM
bp-c54eb80a-5db7-4e82-9e54-c957a2100411	4/11/2010	6:00 PM
bp-2b942de7-eb92-43ec-ae32-9778c2100411	4/11/2010	5:06 PM
bp-7bf31631-2760-44e1-a1f1-fb4972100411	4/11/2010	4:55 PM
bp-a79fe7fd-d168-4f2c-a2ce-3fe792100411	4/11/2010	4:32 PM
bp-c32afe7f-82da-4886-840e-3e99f2100411	4/11/2010	2:35 PM
bp-edbae37f-429a-44c4-97d4-ee8cf2100410	4/10/2010	6:36 PM
bp-bd639fa7-b1ee-4966-8118-3a9e62100410	4/10/2010	1:51 PM
bp-add0f7ff-a498-45f7-95c0-e61042100408	4/8/2010	11:13 PM
bp-9e2c96e3-4c4c-42f9-a17f-230312100407	4/7/2010	5:37 PM
bp-14a22d1d-fcaf-488a-95c1-bbee62100407	4/7/2010	11:54 AM
bp-56c461cd-c81b-49e6-9e74-42a352100405	4/6/2010	12:24 AM
Alright, the only thing I could find was  [@ free | js_json_stringify(JSContext*, unsigned int, int*) ] ,
bp-7bf31631-2760-44e1-a1f1-fb4972100411
please update to firefox 3.6.3 and see if it still crashes.
Summary: I updated to Firefox 3.5.9 recently, and now Firefox crashes multiple times every day. → I updated to Firefox 3.5.9 recently, and now Firefox crashes multiple times every day. [@ free | js_json_stringify(JSContext*, unsigned int, int*) ]

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 553514

Updated

8 years ago
Group: core-security
(Reporter)

Comment 5

8 years ago
This is still happening multiple times every day.  I do not wish to lose my add-ons that are not compatible with 3.6.x, so I do not yet want to go beyond 3.5.9.  Is there a way that I can roll back to 3.5.6, then reinstall a fresh version of 3.5.9 that might be less corrupted?  I want to be able to keep my bookmarks/passwords/history/etc if possible.
(Reporter)

Updated

8 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

8 years ago
Is there anything I should be doing at my end as the user who submitted the bug?  I'm not getting any updates on this bug, but I have gotten updates on bug 553514 that make it sound like you may have figured out a fix, or at least a cause...  

Most of all, I'm wondering is it worthwhile for me to try to roll back to 3.5.8 or 3.5.7? I'd have to install them new as I skipped them the first time thru.
No, there is nothing that needs to be done here. When bug 553514 is fixed, this bug will be fixed too.
We think this is fixed by bug 561592 which will be in Firefox 3.6.4 and 3.5.10. I believe a beta update of 3.5.10 will be released next week with the release to follow the week after that.

The simplest way to make sure you get the beta when it's released may be to install the "Update Channel Selector" add-on and switch to the "beta" channel.
https://addons.mozilla.org/en-US/firefox/addon/6263

If you are comfortable downloading test builds we can point you at our release candidate builds.

Which add-ons are you using that are incompatible with 3.6? I thought we had over 90% compatibility at this point.
Whiteboard: [sg:dupe 553514]
(Reporter)

Comment 9

8 years ago
According to wiki.mozilla.org, it looks like FFx 3.5.10 is scheduled to be released tomorrow (June 1).  Will that solve this bug? 

Also, could I get added to bug 561592 please?  It looks like 553514 is marked as a duplicate of that bug, so I think it would be beneficial to be to see that bug's progress too.

Comment 10

8 years ago
(In reply to comment #9)
> According to wiki.mozilla.org, it looks like FFx 3.5.10 is scheduled to be
> released tomorrow (June 1).  Will that solve this bug? 

We think so.

> 
> Also, could I get added to bug 561592 please? 

Will do.
(Reporter)

Comment 11

8 years ago
Thanks for adding me to 561592, but I'm not sure I'm any less confused on what I should do...do I wait for the release of 3.5.10, or do I do something with the patch above the comments on 561592?  If it's the latter, what do I do with it?  (I'm not a programmer or QA person, so I'll need layman's terms of how to proceed ;)
(Reporter)

Comment 12

7 years ago
It doesn't look like FFx 3.5.10 is going to be released anytime soon, and I'm still crashing constantly...and not all are showing up.  When I check "about:crashes," I only see about 1/3 to 1/2 of all crashes that I know have happened.  I'm going to paste in the IDs in case you might get some helpful info from the latest reports.  Any suggestions of what I can do would be helpful -- and please use laymen's terms, so I'll be sure I don't screw up my browser more than it already is...

Submitted Crash Reports
Report ID                               Date Submitted
      
bp-46c452f2-c6bc-4c14-b9f8-d0d5e2100615	6/15/2010	11:41 PM
bp-0e800fbf-8e66-4d60-93b8-ff0422100615	6/15/2010	11:31 PM
bp-2e9bf6e1-0f28-4de6-b869-6d7102100615	6/15/2010	11:21 PM
bp-8a2ec4d6-2716-4e5a-90a2-967952100615	6/15/2010	10:13 PM
bp-7dde2383-78a9-4863-991a-b20d92100615	6/15/2010	8:10 PM
bp-32b6ddbf-2190-44b4-9962-3fd862100614	6/14/2010	11:59 PM
bp-7b630c37-3456-43c1-af8d-dc3522100614	6/14/2010	8:49 PM
bp-635a60f3-2e2e-4519-8cab-07bba2100613	6/13/2010	10:02 PM
bp-38d2958a-51b2-4965-9b51-8169c2100612	6/12/2010	1:03 PM
bp-a96d06be-9db5-49a1-b657-989242100611	6/11/2010	9:39 PM
bp-c5a02414-8e1f-400b-a850-291cd2100610	6/11/2010	1:22 AM
bp-c2d291d7-38f3-4540-8efb-fd61a2100610	6/10/2010	10:02 PM
bp-b3bc9dcc-c6b9-4d15-b7e7-635342100609	6/9/2010	9:07 PM
bp-86b2bbf0-4aac-4614-87dd-38c712100608	6/9/2010	1:28 AM
bp-bf12488e-b62c-494a-9a0f-3cb0a2100608	6/8/2010	10:55 PM
bp-53c401b8-9811-41ac-9954-a4f1d2100608	6/8/2010	8:32 PM
bp-64365a56-69ea-4232-822e-b000c2100607	6/7/2010	10:50 PM
bp-3af8c6a3-a2aa-424a-861a-e52d52100607	6/7/2010	10:03 PM
7fcd4398-1646-46ee-8fbc-c9fd8cc12f4c	6/7/2010	7:35 AM
bp-11ffd047-354d-4d8e-9eac-c633e2100606	6/6/2010	6:26 PM
bp-aa7cfa8a-387a-4ba0-8760-d8dcb2100606	6/6/2010	2:14 PM
bp-22645367-75d5-4ea0-99bd-9dbc02100606	6/6/2010	12:54 PM
bp-6c6ee81f-dd5a-469e-ac38-6b58d2100606	6/6/2010	12:38 PM
bp-4ee9e5e2-07a5-4726-8105-058a82100606	6/6/2010	11:48 AM
bp-76fa30dc-2967-40ac-86ae-5a4a42100605	6/5/2010	11:18 PM
160140e4-25f4-4e95-bc82-e5f888b03363	6/4/2010	7:59 PM
f412f4da-e3dd-49b8-866c-4da156ef464a	6/1/2010	7:42 AM
bp-45e0ae5f-5cb6-41d8-aa1e-7f84b2100530	5/30/2010	2:57 PM
bp-2e0ec14b-4be1-4ad5-82db-203082100528	5/28/2010	9:54 PM
bp-9cd23a6f-346a-40f8-a484-bc7cd2100528	5/28/2010	10:44 AM
bp-69b0a685-392c-425b-87df-7db472100526	5/26/2010	9:07 PM
bp-c718f363-b6ba-483d-8f2f-1a0cd2100526	5/26/2010	8:37 PM
bp-f91d72f5-2bd3-427c-a02c-9a9802100521	5/21/2010	7:58 PM
bp-d978b885-b17d-4cd0-87c6-817f82100517	5/17/2010	8:34 PM
bp-1e7a9de7-3c9d-4fc3-bb47-cba962100516	5/16/2010	10:35 PM
bp-905ca393-d68a-4eb5-a0e8-82f882100516	5/16/2010	7:58 PM
bp-9894bea5-f52d-480d-9308-483082100516	5/16/2010	7:42 PM
bp-43095dc2-98ff-471f-bd0c-dd4a92100516	5/16/2010	7:31 PM
bp-f1ea75b4-7391-4559-b244-86b382100516	5/16/2010	7:21 PM
bp-8eb80ef5-8492-45e7-bc4b-f6b7e2100516	5/16/2010	7:09 PM
bp-a1f6e10d-17fe-4575-a71b-0c1ed2100516	5/16/2010	6:56 PM
bp-06a95fe3-11b7-435c-b4ad-7fe882100516	5/16/2010	2:01 PM
bp-2857f894-56a6-4cc3-99e0-4384d2100515	5/16/2010	12:47 AM
bp-3812c783-7831-482f-8dc3-124132100515	5/15/2010	5:34 PM
7c4bb894-16cb-4000-b132-8d3959d6c6ee	5/15/2010	6:43 AM
bp-869fefc5-221c-4e9a-9d27-fb19b2100509	5/10/2010	12:38 AM
bp-b1fdfbbd-42c3-4073-a32a-58a7a2100509	5/9/2010	1:16 PM
bp-7b2bfae4-7ad3-4fa8-9a68-b5d182100508	5/8/2010	8:58 PM
bp-9f7a1e3f-11ed-4d02-9e8f-2e3112100506	5/6/2010	9:03 PM
bp-e8095b9b-fac6-4b92-a3e2-1c9632100505	5/6/2010	12:24 AM
bp-ceaadc8e-ffc5-4d7b-9da2-03add2100505	5/5/2010	11:35 PM
bp-21c6773d-c99a-44cb-b36a-bdca12100505	5/5/2010	10:09 PM
bp-2a125509-f8af-402c-9b87-ceb372100505	5/5/2010	3:17 PM
bp-87e1f68c-7473-44a1-81f8-735612100501	5/1/2010	11:42 AM
bp-1da27a12-45a6-4734-a2a3-1358a2100425	4/25/2010	4:16 PM
bp-6c79a0f7-c762-40f9-a145-488032100425	4/25/2010	3:58 PM
bp-a54b1f4f-0871-4edb-a277-5f2c92100425	4/25/2010	12:31 PM
bp-994041c4-796f-4b05-9bbc-ad8362100425	4/25/2010	11:34 AM
bp-57d4a96a-0121-4d44-a183-29fdb2100424	4/25/2010	12:04 AM
bp-8bf98138-96b9-48d8-bc3d-cd0892100424	4/24/2010	10:46 PM
bp-af24ec39-9488-4957-b641-c8a8d2100424	4/24/2010	5:33 PM
bp-ea9ac030-f6eb-475d-8198-41b502100424	4/24/2010	3:04 PM
bp-e1615b9c-58f6-4a53-bd0d-4c43a2100423	4/24/2010	12:10 AM
bp-2fa6ead9-88cb-4b52-9207-e1ab22100423	4/23/2010	11:57 PM
bp-b833365b-5bbb-4cae-a788-92fc42100423	4/23/2010	9:21 PM
bp-041f72ba-3c41-42ee-95c0-44c982100421	4/21/2010	9:30 PM
bp-6c601687-0598-44d6-9122-1b6be2100421	4/21/2010	12:24 PM
bp-8962a2d5-387e-4517-97f1-a98a92100421	4/21/2010	9:28 AM
934a6018-75c2-480a-bbb2-ff02f29825ea	4/20/2010	4:54 PM
bp-75d2e796-e72d-472f-b0de-94ec32100418	4/18/2010	10:34 PM
bp-b77fc887-6608-4bd1-b074-77ed62100417	4/17/2010	10:01 PM
bp-59679048-6d63-4bc5-b122-b63d32100417	4/17/2010	9:40 PM
bp-e3da2c43-8c91-453d-9e38-6b5e12100417	4/17/2010	9:28 PM
5170691b-2cff-4e7a-ab3f-1d6fe6de11bb	4/17/2010	3:04 PM
bp-4d95b4c7-f7a0-4a37-b3b8-de8342100415	4/16/2010	12:06 AM
bp-8fe9bff6-9e47-4b02-8ecf-188ca2100415	4/15/2010	11:52 PM
bp-f308fb81-a872-4a39-a28c-11d062100415	4/15/2010	11:38 PM
bp-1887973a-a60d-46ce-b06a-362802100415	4/15/2010	8:48 PM
bp-0199f720-78e1-4afb-9245-c58342100414	4/15/2010	1:59 AM
bp-5764030e-a79c-4c28-a3bb-fe4562100414	4/14/2010	11:00 PM
bp-9cdb003a-3aaf-423b-bc0b-f26532100413	4/13/2010	10:45 PM
bp-5cebab6b-437e-4543-8682-900412100413	4/13/2010	8:23 PM
bp-4258596e-9108-4a80-97e6-9a3b22100412	4/13/2010	1:05 AM
bp-3ad6186a-78a3-44fd-b52c-d15492100412	4/12/2010	11:52 PM
bp-27852671-6a55-4001-ae11-882872100412	4/12/2010	10:28 PM
bp-934cd7cc-a011-4fed-9146-5b2352100411	4/11/2010	11:07 PM
bp-8db31459-8314-47e3-b487-632c72100411	4/11/2010	6:14 PM
Joanne, wait until 3.5.10 is released . You might also try upgrading to 3.6.3, it has a lot less crashes than 3.5
Joanne, could you give the test build of 3.5.10 a try? Note that it's not the final release, but it should be safe to install to verify that you are not crashing anymore.

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/3.5.10-candidates/build1/win32/en-US/Firefox%20Setup%203.5.10.exe (that's the en-US build; if you need another language, look for your language at http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/3.5.10-candidates/build1/win32/).
If you need any help with testing this, feel free to ping me at djst@mozilla.com.
(Reporter)

Comment 16

7 years ago
hi guys - so one of you says to try the test build, but the other says to wait for the release...any consensus?  And if I do try a test, do I do anything differently from a regular update to make sure I keep my profile intact?  (really don't want to rebuild it yet again...)  I'm still not keen on going up to 3.6.x at home; I used it at work for awhile, and it didn't work with most of my most-needed addons (the new IETab is quite buggy; Unwrap Text was hit-and-miss; Tab History only works thru 3.5.x); we all ended up going back to either 3.5.6 or 3.5.8...
Joanne, if you can't wait, then try the test build. There may be bugs in it, as it is a beta. As for your 3.6.3, a lot more addons are compatible with it now, and you should bug the developers of those addons.
Tyler, the reason why I asked Joanne to try the test build -- aside from potentially letting her continue to use 3.5.x without multiple crashes per day -- was to verify that 3.5.10 indeed fixes the problem. Dan seems to suggest it will in comment 8, but I see no real confirmation of it, so verifying that would be good. Also, Joanne seems comfortable managing profiles, finding info on wiki.mozilla.org, and submitting detailed crash reports, so installing a test build feels straightforward in comparison. :)

Joanne, trying out the test build should be safe. It won't mess up with your profile. And if it doesn't solve the crash issue, you can always just go back to 3.5.9 again by running that installer instead: http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.5.9/win32/en-US/Firefox%20Setup%203.5.9.exe
(Reporter)

Comment 19

7 years ago
Thanks for all of the input -- hope that I can live up to David's compliments :)  I know that a little knowledge can be a dangerous thing if you don't know what it is you don't yet know!

One more question - if I want to have a good backup of my profile, would you recommend FEBE or MozBackup as a better choice?  I have FEBE installed, but haven't used it for a reinstall before, and a coworker mentioned he used MozBackup, but I don't know if the two are incompatible.
(I've responded to Joanne in a separate e-mail.)
(Reporter)

Comment 21

7 years ago
FFz just popped up an alert that 3.5.10 is an available upgrade, so I'm going to try to get that done and let you know if I'm still crashing after some usage.
(Reporter)

Comment 22

7 years ago
I did update to the official 3.5.10 release, but even in the little time I've used it, I've crashed at least 3 times.  Here are two of the reports since FFx update (forgot to save at least one):
Report ID                                Date Submitted
bp-ccf3ed1b-6f4c-4c42-a87b-44c552100625	  6/25/2010	4:26 PM
bp-22480c60-3e2d-470e-be3b-8a1ec2100624	  6/24/2010	8:40 PM
(Reporter)

Comment 23

7 years ago
3.5.10 is crashing as much or more than 3.5.9, so I'm unsure what to try next -- any ideas?

latest saved crash reports:  (at least 2 other reports this afternoon did not save; I think these were the ones that crashed withing just a few minutes of reloading FFx)
Report ID                                Date Submitted
bp-6b6957cc-f839-45ae-8105-3008a2100630	6/30/2010	2:33 PM
bp-53e174f0-4ccc-45de-bb00-955d72100630	6/30/2010	1:59 PM
bp-ea2ce551-5941-42bf-81fb-116f8b84a2a0	6/30/2010	8:20 AM --note I was not even at the computer for this one, had been asleep for 4.5 hours!
bp-80178425-ffaa-4a91-9b61-c795b2100630	6/30/2010	3:46 AM
bp-ff3c9e9b-7c60-4488-88e8-af7562100630	6/30/2010	3:35 AM
bp-0c33f2a6-9348-442f-b412-e0b902100629	6/30/2010	2:52 AM
bp-07006319-633a-4a6c-822f-ff9a12100629	6/30/2010	2:37 AM
bp-a43ec97e-359c-4568-934a-8746b2100628	6/28/2010	2:27 PM
bp-0a8ef611-d684-42b3-a8b7-f75252100627	6/27/2010	12:42 PM
bp-dea815ab-669d-4d56-97aa-165472100626	6/26/2010	10:15 PM
bp-bfaa7ddf-f54a-48d5-a161-4a65e2100626	6/26/2010	7:03 PM
(Reporter)

Comment 24

7 years ago
waving the white flag -- after over 15 crashes in 24 hours, I have backed up my profile, uninstalled FFx, rebooted, and reinstalled a fresh download of 3.5.10...here's hoping for a better result.

Comment 25

7 years ago
does look like there might be a 3.5.10 regression here based on volume changes, but maybe that's just users moving up to 3.5.10. 

checking --- js_json_stringify.JSContext...unsigned.int..int.. 20100627-crashdata.csv
found in: 3.5.10 3.5.9 3.6.6 3.5.8
release total-crashes
              js_json_stringify.JSContext...unsigned.int..int.. crashes
                         pct.
all     419135  157     0.000374581
3.5.10  16696   133     0.00796598
3.5.9   22167   22      0.000992466
3.6.6   45753   1       2.18565e-05
3.5.8   574     1       0.00174216

 A month ago most of crashes were on 3.5.9, 

checking --- js_json_stringify.JSContext...unsigned.int..int.. 20100527-crashdata.csv
found in: 3.5.9 3.5.8 3.5.10
release total-crashes
              js_json_stringify.JSContext...unsigned.int..int.. crashes
                         pct.
all     367855  230     0.000625246
3.5.9   32443   222     0.00684277
3.5.8   1076    6       0.00557621
3.5.10  339     2       0.00589971


and three months ago were on 3.5.8 but at lower volume

checking --- js_json_stringify.JSContext...unsigned.int..int.. 20100327-crashdata.csv
found in: 3.5.8
release total-crashes
              js_json_stringify.JSContext...unsigned.int..int.. crashes
                         pct.
all     308682  61      0.000197614
3.5.8   32775   61      0.00186117

isolation of the volume increase window seems like one thing to probe deeper on




os breakdown shows 100% WinXP

comment 16 mentions an interesting set of addons that inhibited upgrade to 3.6.x,  maybe they are getting in the way of 3.5.10 too as joanne tries that..

 (the new IETab is quite buggy; Unwrap Text was
hit-and-miss; Tab History only works thru 3.5.x); we all ended up going back to
either 3.5.6 or 3.5.8...

closer inspection and adding/removing each one of those with 3.5.10 seems like one step to take.  Checking the correlations of those addons to this signature would be another step.

I'm away from the office this week with spotty network connections, but maybe others can help out investigating some of this.
(Reporter)

Comment 26

7 years ago
Keeping fingers crossed that I am not jinxing myself, but so far so good...no crashes since the re-install last night.  I even loaded some flash-heavy sites and purposely pushed capacities by eventually opening many tabs in 5 separate windows as a test.  I'll keep you guys updated if anything changes...
(Reporter)

Comment 27

7 years ago
never mind that last comment, Murphy's Law still rules, as I crashed less than 2 minutes after that post.
(Reporter)

Comment 28

7 years ago
latest crashes:
Report ID                                        Date Submitted
bp-42f5ba03-d22d-4817-bfb0-6e95d2100711	7/11/2010	11:44 PM
bp-62aeefe1-0451-4374-9651-eeda92100710	7/10/2010	11:28 PM
bp-1253681a-ec43-4d48-bf81-79a182100709	7/9/2010	4:52 PM
bp-5f73629b-b586-4d2b-a0b4-e20a62100705	7/5/2010	4:06 AM
bp-0d41d153-0488-4fe2-b5d1-af27b2100703	7/3/2010	10:47 PM
bp-42cb19c6-471b-4cc5-880a-cf9bc2100702	7/2/2010	3:23 PM
bp-319aff0d-0378-48b1-b467-0c92b2100701	7/2/2010	1:16 AM

Comment 29

7 years ago
It looks like this bug has been fixed in 3.6.x version, unless we aren't reading the data right.   Might be worth another try on 3.6.6 to help confirm that the fix for bug 561592 actually worked right for 3.6.6, even though it appears that the fixed didn't take right on 3.5.8.

The reasons given for not upgrading to included

> the new IETab is quite buggy

Maybe https://addons.mozilla.org/en-US/firefox/addon/92382/  IE Tab 2 (FF 3.6+)  2.5.10.1 by ietab.net might be the solution here.

> Unwrap Text was hit-and-miss; 

https://addons.mozilla.org/en-US/firefox/addon/1288/ now appears compatible with 3.6.*.  were there other problems?


>Tab History only works thru 3.5.x);

A review comment on https://addons.mozilla.org/en-US/firefox/addon/1859/ says it works with 3.6.x even though it hasn't been marked as such.  You could try the beta that has been posted or over ride the version compatibilty check.
(Reporter)

Comment 30

7 years ago
too many crashes, so I've thrown in the towel on 3.5.10 and installed 3.6.6; I'll let you guys know if I'm still crashing.

I'm trying IE Tab Plus this time; IE Tab 2 is the one that was so buggy at work.

fingers crossed that Unwrap Text will work now :)

I can't figure out how to override the version compatibility check -- any links on how to do this?  meanwhile, I'll try that beta on my next reboot...
(Reporter)

Comment 31

7 years ago
So, no crashes, but I haven't really been able to do much surfing to test it out b/c 3.6.6 has been freezing up.  I've had to do hard closes via Task Mgr b/c no menus at all can be accessed unless I am willing to wait at least TWO minutes from the click (right or left).  The only surfing I can do is via a left click within the page and even that loads slower than before. Left clicking does not work -- I can see the outline of the window of choices, but it doesn't fill in the text...I let it sit over three minutes on each try before giving up and hitting ESC, which itself takes about a minute to take effect.

I did a full reboot after installing 3.6.6, and I've tried closing and re-opening FFx.  In case I never said before, I'm on XP SP3, in case that matters.

I've noticed a distinct slowdown of menu- and tab-loading since I first updated to 3.5.9, more so in 3.5.10, and to the extreme now in 3.6.6...is there anything I can fix at my end to stop this degradation?
(Reporter)

Comment 32

7 years ago
I'm not sure if I should open a new bug, but the slow-down issue has me ready to abandon Ffx and look for a new browser...as noted above, sometimes the slow-down manifests by actual slow typing or scrolling, and other times by a menu opening as blank, if at all.

Here is a list of my crashes that registered (I know that there have been more crashes than this, and no log exists for when I have to force Ffx to close via Task Manager):

Submitted Crash Reports     
Report ID  	                         Date Submitted
bp-19d4b465-701f-4b25-b961-b62932100916	9/16/2010	4:22 PM
bp-4a8ad6c9-0546-441a-9714-80c632100914	9/14/2010	5:00 PM
92380835-3b4a-41e1-9464-4c03816f2f3d	9/3/2010	1:48 AM
bp-0c584785-acef-4531-9651-51b892100823	8/24/2010	2:18 AM
2d3e44d7-87da-4a82-899a-ea083dfb6cc3	8/23/2010	11:42 PM
733e5734-439a-4a3c-b87e-5823af582661	8/23/2010	11:42 PM
bp-89005e0c-48e5-4006-b418-736122100823	8/23/2010	8:42 AM
bp-42080632-2033-4c21-ad97-e09af2100818	8/19/2010	2:48 AM
bp-49c069d4-a88b-40a2-8779-3dbad2100811	8/11/2010	11:04 PM
bp-dfe060a9-b5d2-4b07-930a-897052100804	8/4/2010	11:10 PM
bp-2e836368-8dd7-4473-a552-faca32100804	8/4/2010	11:10 PM
bp-dda9d971-fac4-42cd-a1ea-0500e2100803	8/3/2010	3:55 PM
bp-b2d899ec-2ac1-4bb4-9769-9b0722100803	8/3/2010	3:55 PM
bp-da2197ba-6073-454f-86af-270452100801	8/1/2010	10:46 PM
22e891f3-29d7-4cee-90ed-749f0b93f513	7/31/2010	10:21 PM
4b8c5d6e-4ae7-46b1-8fe8-b6fa74f6e95b	7/22/2010	12:08 AM
bp-36bc3e77-04d1-428e-81ec-4085f2100720	7/21/2010	1:21 AM
bp-889caf15-ea23-4a24-84a8-4e09d2100714	7/14/2010	4:01 PM
bp-0eafeea8-899e-4360-b1bc-b1f972100712	7/12/2010	11:41 PM
bp-b7eb2076-68b7-45b4-8fe6-308cb2100712	7/12/2010	11:21 PM
bp-1e84344c-6cfa-48c2-a10e-cb0f52100712	7/12/2010	8:34 PM
bp-42f5ba03-d22d-4817-bfb0-6e95d2100711	7/11/2010	11:44 PM
bp-62aeefe1-0451-4374-9651-eeda92100710	7/10/2010	11:28 PM
bp-1253681a-ec43-4d48-bf81-79a182100709	7/9/2010	4:52 PM
bp-5f73629b-b586-4d2b-a0b4-e20a62100705	7/5/2010	4:06 AM
bp-0d41d153-0488-4fe2-b5d1-af27b2100703	7/3/2010	10:47 PM
bp-42cb19c6-471b-4cc5-880a-cf9bc2100702	7/2/2010	3:23 PM
bp-319aff0d-0378-48b1-b467-0c92b2100701	7/2/2010	1:16 AM

Comment 33

7 years ago
Joanne:

Can you please try one thing: Run Firefox with a brand new profile, without all of the overhead of extensions and accumulated cruft.  http://support.mozilla.com/en-US/kb/Managing+profiles has instructions for starting the profile manager and creating a new profile.  Then try Firefox and see if it's faster.

According to your latest crash report, you're running Firefox with 3 different versions of Java (none of which are up to date), a number of old extensions, toolbars that will slow performance, WoT (which adds a lookup for every link on a page) and some things I don't even recognize.
Group: core-security
You need to log in before you can comment on or make changes to this bug.