compile warnings on optimized Linux builds

RESOLVED DUPLICATE of bug 558410

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 558410
8 years ago
8 years ago

People

(Reporter: njn, Assigned: njn)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

8 years ago
These appear to have been introduced by bug 553671:

In file included from ../jshashtable.h:46,
                 from ../jscntxt.h:55,
                 from ../jscntxt.cpp:55:
../jstl.h: In member function ‘T& js::LazilyConstructed<T>::asT() [with T = js::AutoLockGC]’:
../jstl.h:271:   instantiated from ‘js::LazilyConstructed<T>::~LazilyConstructed() [with T = js::AutoLockGC]’
../jstl.h:305:   instantiated from here
../jstl.h:266: warning: dereferencing type-punned pointer will break strict-aliasing rules

../jscntxt.h: In function ‘JSContext* js_ContextIterator(JSRuntime*, JSBool, JSContext**)’:
../jscntxt.h:1954: warning: dereferencing pointer ‘<anonymous>’ does break strict-aliasing rules
../jstl.h:284: note: initialized from here

In file included from ../jshashtable.h:46,
                 from ../jscntxt.h:55,
                 from ../jsgc.cpp:63:
../jstl.h: In member function ‘T& js::LazilyConstructed<T>::asT() [with T = js::AutoUnlockGC]’:
../jstl.h:271:   instantiated from ‘js::LazilyConstructed<T>::~LazilyConstructed() [with T = js::AutoUnlockGC]’
../jstl.h:305:   instantiated from here
../jstl.h:266: warning: dereferencing type-punned pointer will break strict-aliasing rules

../jscntxt.h: In function ‘void js_GC(JSContext*, JSGCInvocationKind)’:
../jscntxt.h:1962: warning: dereferencing pointer ‘<anonymous>’ does break strict-aliasing rules
../jstl.h:284: note: initialized from here

../jscntxt.h: In function ‘void T.580(JSContext*)’:
../jscntxt.h:1962: warning: dereferencing pointer ‘<anonymous>’ does break strict-aliasing rules
../jstl.h:284: note: initialized from here


BTW, can anyone explain to me what these "T.580()" functions are?  I've seen them before.  Are they related to explicit constructors?
(Assignee)

Comment 1

8 years ago
This is with GCC 4.4.1.
Dup of bug 558410 (I watch the JS Engine component).

/be
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 558410
You need to log in before you can comment on or make changes to this bug.