Cannot attach files using Yahoo through a proxy server, just hangs. Works in IE.

RESOLVED DUPLICATE of bug 562880

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 562880
8 years ago
8 years ago

People

(Reporter: mg, Unassigned)

Tracking

3.6 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday0504], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)

Cannot attach files using Yahoo through a proxy server, just hangs. When the file progress bar is done moving to the right, a authentication window pops up.  After entering the credentials, nothing happens.  When I try to "remove" the attachment, Firefox hangs with a hourglass cursor and I have to click close to force it shutdown. Yahoo mail and FF otherwise work fine without attachments through proxy server.  I am not sure if this happens when Yahoo tries to do a virus scan?

Attaching files works okay using IE. If I started writing an email using FF, I save a draft in FF and log into Yahoo with IE to attach the file.

This has been going on for months and I am just writing now due to the frustration level!

Thanks.

Reproducible: Always

Steps to Reproduce:
1. Connect to Internet through proxy server
2. Create email in Yahoo, attach document.
3. Authentication window pops up.
4. Credentials entered.
5. Nothing else happens, browser hangs.



Attached the document successfully.
Does safe mode help?
http://support.mozilla.com/en-US/kb/Safe+mode
Version: unspecified → 3.6 Branch
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Does safe mode help?
> http://support.mozilla.com/en-US/kb/Safe+mode

No, the same result in Firefox Safe Mode.  Thanks.

Comment 3

8 years ago
Adobe's Flash player is used to upload the file, it is known not to pick up proxy settings from Firefox or the system. The workaround for this is to use the Yahoo Mail Classic interface till Adobe fixes the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 562880

Updated

8 years ago
Whiteboard: [bugday0504]
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> Adobe's Flash player is used to upload the file, it is known not to pick up
> proxy settings from Firefox or the system. The workaround for this is to use
> the Yahoo Mail Classic interface till Adobe fixes the issue.
> 
> *** This bug has been marked as a duplicate of bug 562880 ***


I did not understand that Firefox uses Adobe's Flash for all file uploads-is that a correct interpretation of the problem?
No, Kevin means that yahoo is using flash to do file uploads.
(I don't have a yahoo Account and can not check it)
The flash Plugin (the plugin versions for all browsers except IE) itself doesn't pick up proxy settings from Gecko or the system.
(Reporter)

Comment 6

8 years ago
(In reply to comment #5)
> No, Kevin means that yahoo is using flash to do file uploads.
> (I don't have a yahoo Account and can not check it)
> The flash Plugin (the plugin versions for all browsers except IE) itself
> doesn't pick up proxy settings from Gecko or the system.

Ah, thank you for explaining.
You need to log in before you can comment on or make changes to this bug.