If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Frame being clipped in frameset

RESOLVED INVALID

Status

()

Core
Layout: HTML Frames
P3
normal
RESOLVED INVALID
17 years ago
16 years ago

People

(Reporter: Chris Petersen, Assigned: Eric Vaughan)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Build: 2000100910
Platform: All
Expected result: Frame should display it's entire content.
What I get: Bottom portion of top frame's content is cropped.
Steps to reproduce:

1) Go to www.sears.com

2) Notice that the content in top frame is cropped at the bottom.
(Reporter)

Comment 1

17 years ago
Created attachment 16554 [details]
The sears.com frameset
(Reporter)

Comment 2

17 years ago
The frameset specifies three rows:
<frameset rows="0,99,*"frameborder="NO" border="0" framespacing="0">

Comment 3

17 years ago
This bug is caused by a stray <form> tag in the source of the top frameset. 
Specifically, this chunk of html:

    <form name="keywordForm" method="post"
action="http://www.sears.com/jsp-scripts/framework/home.jsp" target="_top"
onSubmit="return( fn_kw_checkKeyword() );"> 
    <input type=hidden name="BV_SessionID"
value="@@@@0624058002.0971139059@@@@">
<input type=hidden name="BV_EngineID" value="kaljddddhgjbgfbmgclchl.0">
<input type=hidden name ="targetPage" value="/mercado/searchall.jsp"><input
type=hidden name ="vertical" value="SEARS">
    
        <table width="100%" border="0" cellspacing="0" cellpadding="0"
bgcolor="#333399"><form>  <-*************Extra*<form>*tag************
          <tr bgcolor="#333399"> 

This form tag causes us to close the containing form, which causes us to demote
the containing form from a container to a leaf, which means that the bottom form
margin (see bug 41806 for why it's there) is after the containing form but
*before* the blue table cell, shifting it down on the page.

This is a malformed page, so the bug is invalid.  We should be backwards
compatabile with Nav here, but simply turning off the bottom margin on the form 
would break an equal number of other sites that depend on that bottom margin
being there.  A more complete understanding of what Nav does is required to fix
this bug.  Will look at this after RTM.
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 4

17 years ago
QA Contact update
QA Contact: petersen → amar
Bulk reassignin HTML FRAME/IFRAME bugs to Eric.
Assignee: pollmann → evaughan
Status: ASSIGNED → NEW
URL in question seems to work, now, and per Pollmann's comments bug is due to
invalid HTML and hard to fix without breaking other things. Therefore closing as
INVALID.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.