clicking a link on this message loads web page in message area

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
18 years ago
14 years ago

People

(Reporter: waterson, Assigned: mscott)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
To reproduce the problem:

1. Save the (soon to be attached) message as

     ${PROFILE}/Mail/Local\ Folders/Test

   on your computer. (This will create a folder called "Test" in
   your "Local Folders" account.)

2. (Re)start mozilla, so that mailnews will scan the "Local Folders"
   directory and detect the new folder.

3. Open the message. You should see "NASTC News...Fall 2000".

4. Click on a link in the message; e.g., "new web site".

Expected: new browser window is opened displaying web page

Actual: web page is opened "in place" in the message area.
(Reporter)

Comment 1

18 years ago
Created attachment 16568 [details]
the evil message

Comment 2

18 years ago
This is true for bookmarks also. If you click on the Bookmark link in the 
sidebar of the mail window, it is displayed in the message pane.
I can see the bug on WinNT4 sp6 Mozilla 0.9.6. This is definitely a problem
because the web page is displayed instead of the message w/o any indication of
this state and any web toolbars.
It is possibly related to to bug 90992.

The behavior is exactly opposite to what I would expect:

- in the three pane view, the message should open in a new browser window/tab or
otionally (I mean confugurable by an option :) in browser window tab that was
viewed first/last by the user. 

- in single message view I would expect the window to show the link in the same
window (exchanging the toolbars and menus) unless new window was explicitly
requested. ..there may be an issue with `back' button in this case.

Comment 4

15 years ago
Chris Waterson, is this bug still a problem for you?  I am unable to reproduce 
the symptom with Mozilla 1.4, and I expect it's been fixed for longer than that.

If it's working OK for you, please mark this bug   Resolved|WorksForMe.

Comment 5

15 years ago
=>WFM, no response from reporter
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.