Closed Bug 559019 Opened 10 years ago Closed 10 years ago

Incorrect organizer when account name contains a comma

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect, major)

x86
Linux
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 492069

People

(Reporter: spam+bugzilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.9) Gecko/20100401 Ubuntu/9.10 (karmic) Firefox/3.5.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1

The ORGANIZER property in an event is not set correctly if the 'Your name' property of the mail account contains a comma (i.e. in the format Last, First).

Reproducible: Always

Steps to Reproduce:
1. Have a mail account with the 'Your Name' property set to Last, First
2. Create a new event and invite some one
3. Sent the event
4. Open the event in the Sent Items box
Actual Results:  
The invitation sent/received will contain 'Organizer: Last'. It does not contain the full name, nor the e-mail address.

Source is: ORGANIZER;RSVP=TRUE;PARTSTAT=ACCEPTED;ROLE=CHAIR:Last

Expected Results:  
If the 'Your name' property does not contain a comma, the source looks like:

ORGANIZER;RSVP=TRUE;CN=First Last;PARTSTAT=ACCEPTED;ROLE=CHAIR:mailto:first.last@example.com

Both CN and mailto are missing in the actual invitation


Probably related to Bug 427949 That bug is about the names of the invitees, this is about the name of the organiser.
See Bug 492069. I don't think there is a difference in handling of organizer and attendees. The former is just a special case of the latter.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 492069
You need to log in before you can comment on or make changes to this bug.