mozilla-central/netwerk should be mozilla-central/network

VERIFIED WONTFIX

Status

()

VERIFIED WONTFIX
9 years ago
4 years ago

People

(Reporter: erappleman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a4pre) Gecko/20100407 Ubuntu/10.04 (lucid) Firefox/3.7a4pre
Build Identifier: 

This one is pretty straightforward. A major folder has its name misspelled

hg clone http://hg.mozilla.org/mozilla-central/
cd mozilla-central/netwerk

Reproducible: Always
It's not misspelled. ;)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Component: Build Config → Networking
QA Contact: build-config → networking
Hardware: x86 → All
Resolution: --- → WONTFIX
Yeah this is intentional. I believe this has historical reasons because netwerk/ is a rewrite of older code in network/, so it needed a new name while the two directories co-existed. We could rename this, but I'm not sure it's worth the effort.
Status: RESOLVED → VERIFIED

Comment 3

4 years ago
This is a question mark to almost every newcomer to Mozilla.
(I thought it was misspelled once upon a time).
Perhaps we can put the historical reason somewhere, such as Necko's wiki page or FAQ. :)
(In reply to Ethan Tseng [:ethan] from comment #3)
> Perhaps we can put the historical reason somewhere, such as Necko's wiki
> page or FAQ. :)

its a wiki.. its a community project.. you seem to have an itch..

Comment 5

4 years ago
You are right!  Because several people asked me the same question.
I'll edit the wiki to stop my itch. ;)
You need to log in before you can comment on or make changes to this bug.