uneval(this) dies in shell builds with Error: not a CType

RESOLVED DUPLICATE of bug 569666

Status

()

RESOLVED DUPLICATE of bug 569666
9 years ago
9 years ago

People

(Reporter: Waldo, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Shell-only, browser builds not affected (hence no tinderbox orange).

Comment 1

9 years ago
'ctypes.toSource()' does the same thing, doubtless because of the various prototypes whose toSource() functions expect actual CTypes and CDatas.

Not sure what convention is to get around this.
You could make some properties non-enumerable.

Or make e.g. ctypes.CType.prototype.toSource() return "CType.prototype".

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 569666
You need to log in before you can comment on or make changes to this bug.