"Duplicate Tab" needed in tab context menu

RESOLVED DUPLICATE of bug 455722

Status

()

enhancement
RESOLVED DUPLICATE of bug 455722
9 years ago
9 years ago

People

(Reporter: drankinatty, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100401 SUSE/3.6.3-1.1 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100401 SUSE/3.6.3-1.1 Firefox/3.6.3

Guys,

    I find myself repeatedly needing a "Duplicate Tab" option in the context menu when you rt-click on a tab. Say for example you have navigated from a link to a wiki page that needs input, but you would like to continue browsing from where you came from. If you are in the middle of an edit, you options are to quit editing and go back and re-open the wiki in a separate tab (to many clicks), create a new tab and fumble through history to find the link (again too many clicks), 

It would be very efficient to have a "Duplicate Tab" option so all that is required is a rt-click -> Duplicate Tab -> back (now that's clean)

Would be a great upstream feature to add.


Reproducible: Always
Think this should be an addon, in face, https://addons.mozilla.org/en-US/firefox/addon/28 does this, but it is slightly outdated.
Whiteboard: [WONTFIX?]
Version: unspecified → Trunk
(In reply to comment #0)
> If you are in the middle of an edit, you options are to
> quit editing and go back and re-open the wiki in a separate tab (to many
> clicks), create a new tab and fumble through history to find the link (again
> too many clicks),

Note that you can middle-click the back button.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Whiteboard: [WONTFIX?]
Duplicate of bug: 455722
You need to log in before you can comment on or make changes to this bug.