Internal error when attempting to browse the Administration>Parameters page

RESOLVED WORKSFORME

Status

()

Bugzilla
Administration
--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Jeff, Unassigned)

Tracking

x86
Windows Server 2003

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1045 Safari/532.5
Build Identifier: 3.6

After installing bugzilla 3.6 on my Windows 2003 Server box using the CVS upgrade option I now receive internal error when I browse to the Parameters page.


Reproducible: Always

Actual Results:  
Bugzilla has suffered an internal error. Please save this page and send it to admin@fakeurl.com with details of what you were doing at the time this message appeared.

URL: http://fakeurl.com/bugzilla/editparams.cgi

file error - admin/params/example.html.tmpl: not found
admin/params/example.html.tmpl is not part of a normal Bugzilla installation.
(Reporter)

Updated

8 years ago
OS: Other → Windows Server 2003
Version: unspecified → 3.6
Custom scripts are a support issue. The place to ask about that would be the
support-bugzilla mailing list, described here:

  http://www.bugzilla.org/support/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

8 years ago
The problem is that I don't have any custom scripts. I simply followed the regular upgrade instructions on a default installation with no customizations. So as I see it this is still the correct place to raise this issue.

I also get some strange errors when doing a sanity check about users not being Australian. I didn't know that being Austrailin was a requirement to use Bugzilla (jk). 

EXAMPLE PLUGIN - Checking for non-Australian users.
User <user1@fakeuri.com> isn't Australian. Edit this user.
User <user2@fakeuri.com> isn't Australian. Edit this user.
User <user3@fakeuri.com> isn't Australian. Edit this user.

Perhapse some non-production code made it's way into the stable release tag? Below is the command that I used when upgrading as suggested by the online documentation.

cvs update -R -d -rBugzilla_Stable
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Ah, ok... in your extensions/ folder, you should see an "Example" directory. Inside of it, check for an empty file named "disabled". If you do not see it, create a file named "disabled". That will solve your problem. I have a feeling the CVS upgrade pruned the empty file. I'll see if we can add an empty line or something to the file to keep it from disappearing.
(Reporter)

Comment 5

8 years ago
Reed, That seemed to do the trick. Thanks for the workaround. 

I've also noticed a bunch of dead files that are no longer part of the repository after upgrading. I'm not sure if this is another symptom of the CVS upgrade or not but it would be great if these could be cleaned up automatically as well. I'm not so sure how that works with CVS (I'm more of a SVN guy).

Comment 6

8 years ago
(In reply to comment #3)
> cvs update -R -d -rBugzilla_Stable

  That's not the line from the Bugzilla Guide. It should be:

 cvs -q update -dP -rBugzilla_Stable
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.