The counter is not displayed correctly

VERIFIED DUPLICATE of bug 57968

Status

()

Core
ImageLib
P3
normal
VERIFIED DUPLICATE of bug 57968
17 years ago
17 years ago

People

(Reporter: Shao Zhang, Assigned: pnunn)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
At the bottom of the page, there is a little counter. It seems that mozilla is
not passing the right parameters to the cgi script. The relevant source is:
<h2>There have been people <img src="http://www.cia.com.au/cgi-bin/Count.cgi?
df=guyb.dat|dd=C|ft=0|" align=absmiddle>

I guess mozilla treats the '|' differently?

Produced using the build 2000100809 under Debian GNU/Linux 2.2
Crossed checked with netscape 4.75/IE 5 and it works fine.

Comment 1

17 years ago
http://www.cia.com.au/cgi-bin/Count.cgi?df=guyb.dat|dd=C|ft=0| loads correctly
when hitting it directly, not in the html.  over to imagelib
Assignee: asa → pnunn
Status: UNCONFIRMED → NEW
Component: Browser-General → ImageLib
Ever confirmed: true
QA Contact: doronr → tpreston
(Assignee)

Comment 2

17 years ago
Interesting.
If you view the cgi generated image, it works.
View it in the page, it chokes.
-pn

Status: NEW → ASSIGNED
Target Milestone: --- → M18

Comment 3

17 years ago
Created attachment 17208 [details]
CGI free test case

Comment 4

17 years ago
The problem appears to be that a newline character in the HTML source ends up in
the reference URL. In the CGI example, it complains about the %0A but simple
image files also have this problem. View page info also shows the controls.

Comment 5

17 years ago
This is a duplicate of bug 57968, which I have a fix for.  Marking this a duplicate!

*** This bug has been marked as a duplicate of 57968 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
Status: RESOLVED → VERIFIED

Comment 6

17 years ago
Per  Eric Pollmann's comments, I am marking as verified duplicate
You need to log in before you can comment on or make changes to this bug.