clarify documentation for install guide for the sdk

RESOLVED FIXED

Status

RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: fiveinchpixie, Assigned: fiveinchpixie)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: jetpack-sdk 0.2rc2

Modify the documentation to include stepwise instructions for installing and activating the sdk; particular clarity to path definition.

Reproducible: Always

Steps to Reproduce:
if the path does not include the python libs directory, windows (particularly) is not able to run cfx or any of the tools properly
Actual Results:  
'python' not defined...

Expected Results:  
installing and operating the cfx tool
Noelle mentioned to me that she can take this on, so assigning it to her.
Assignee: nobody → fiveinchpixie
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 2

9 years ago
Created attachment 441657 [details] [diff] [review]
proposed patch, see comment

I added a small section about verifying/adding python to the path and did a little bit of wordsmithing for a bit more clarity. I don't want to fully overhaul it as it seems to be working out okay as it is.
Comment on attachment 441657 [details] [diff] [review]
proposed patch, see comment

Looks good, with the nit that it looks like a couple lines sprung extra trailing spaces unnecessarily.

r=myk, and this is low-risk so acceptable during the 0.3 freeze.  Thus I'll commit it before spinning the 0.3rc2 build.
Attachment #441657 - Flags: review+
Fixed by changeset https://hg.mozilla.org/labs/jetpack-sdk/rev/06031b56312a.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
Version: 0.2 → unspecified
You need to log in before you can comment on or make changes to this bug.