Text color not reset when switching stylesheet to "None"

VERIFIED DUPLICATE of bug 47760

Status

()

P3
normal
VERIFIED DUPLICATE of bug 47760
18 years ago
18 years ago

People

(Reporter: bugzilla, Assigned: pierre)

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
In nightly build 20001005 under Win2K:

When selecting "None" from the alternatives in "View | Use style sheet", the
text color is not reset to the default.

For example, say your default colors are basic black on white. You visit a page
that doesn't have colors in the <body> tag and uses a named style sheet like:

body { color: white; background-color: black; }

If you then switch from the named style sheet to "None", the link and background
colors will change to the browser defaults, but the text will remain white,
which can render the page unreadable.
(Reporter)

Comment 1

18 years ago
Created attachment 16620 [details]
Bug demo stylesheet
(Reporter)

Comment 2

18 years ago
Created attachment 16621 [details]
Test page demonstrating bug (uses style sheet above)

Comment 3

18 years ago
Changing to Style System component, cc'ing attinasi, just a hunch he may have

some ideas on this.
Assignee: clayton → pierre
Component: Layout → Style System
QA Contact: petersen → chrisd
(Assignee)

Comment 4

18 years ago
I guess it comes from the BodyFixupRule. If you change the rule in the attached 
stylesheet to act on the H1 instead of the Body, it works. We need a way to 
remove the BodyFixupRule when we switch from an alternate stylesheet to 'none' or 
to another alternate stylesheet.
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 5

18 years ago
I think this is related to (or dup of?)  bug 47760.
Suggest: platform=all, OS=all.
(Assignee)

Comment 6

18 years ago
Correct: dup of 47760.


*** This bug has been marked as a duplicate of 47760 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.