Closed Bug 559436 Opened 14 years ago Closed 14 years ago

Silverlight plugin crash [@ google_breakpad::ExceptionHandler::WriteMinidumpOnHandlerThread][@ base::MessagePumpForUI::ProcessMessageHelper]

Categories

(Core Graveyard :: Plug-ins, defect)

x86
Windows 7
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 560932

People

(Reporter: martijn.martijn, Unassigned)

References

()

Details

(Keywords: crash, Whiteboard: [fixed by bug 560932?])

Crash Data

Nice that plugin crashes are finally processed on Socorro!
For some reason, I get actually 2 crash report per Silverlight plugin crash:
http://crash-stats.mozilla.com/report/index/bp-b9f67512-9284-404a-a925-28bff2100414
http://crash-stats.mozilla.com/report/index/bp-23480a6c-8834-4760-9340-390f92100414


http://crash-stats.mozilla.com/report/index/bp-b9f67512-9284-404a-a925-28bff2100414
0  	ntdll.dll  	KiFastSystemCallRet  	
1 	ntdll.dll 	ZwWaitForSingleObject 	
2 	KERNELBASE.dll 	WaitForSingleObjectEx 	
3 	kernel32.dll 	kernel32.dll@0x4f002 	
4 	kernel32.dll 	kernel32.dll@0x4efb1 	
5 	xul.dll 	google_breakpad::ExceptionHandler::WriteMinidumpOnHandlerThread 	toolkit/crashreporter/google-breakpad/src/client/windows/handler/exception_handler.cc:691
6 	xul.dll 	google_breakpad::ExceptionHandler::WriteMinidumpForException 	toolkit/crashreporter/google-breakpad/src/client/windows/handler/exception_handler.cc:706
7 	xul.dll 	google_breakpad::ExceptionHandler::WriteMinidump 	toolkit/crashreporter/google-breakpad/src/client/windows/handler/exception_handler.cc:748
8 	xul.dll 	CrashReporter::CreatePairedMinidumps 	toolkit/crashreporter/nsExceptionHandler.cpp:1726
9 	xul.dll 	mozilla::plugins::PluginModuleParent::ShouldContinueFromReplyTimeout 	dom/plugins/PluginModuleParent.cpp:226
10 	xul.dll 	mozilla::ipc::SyncChannel::ShouldContinueFromTimeout 	ipc/glue/SyncChannel.cpp:258
11 	xul.dll 	mozilla::ipc::RPCChannel::Call 	ipc/glue/RPCChannel.cpp:214
12 	xul.dll 	mozilla::plugins::PPluginInstanceParent::CallNPP_HandleEvent 	obj-firefox/ipc/ipdl/PPluginInstanceParent.cpp:327
13 	xul.dll 	mozilla::plugins::PluginInstanceParent::NPP_HandleEvent 	dom/plugins/PluginInstanceParent.cpp:727
14 	xul.dll 	mozilla::plugins::PluginModuleParent::NPP_HandleEvent 	dom/plugins/PluginModuleParent.cpp:484
15 	xul.dll 	nsNPAPIPluginInstance::HandleEvent 	modules/plugin/base/src/nsNPAPIPluginInstance.cpp:1378
16 	xul.dll 	nsPluginInstanceOwner::ProcessEvent 	layout/generic/nsObjectFrame.cpp:4606
17 	xul.dll 	nsPluginInstanceOwner::DispatchMouseToPlugin 	layout/generic/nsObjectFrame.cpp:4000
18 	xul.dll 	nsPluginInstanceOwner::MouseDblClick 	layout/generic/nsObjectFrame.cpp:3982
19 	xul.dll 	nsEventListenerManager::HandleEvent 	content/events/src/nsEventListenerManager.cpp:1194
20 	xul.dll 	nsEventTargetChainItem::HandleEvent 	content/events/src/nsEventDispatcher.cpp:201
21 	xul.dll 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:326
22 	xul.dll 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:604
23 	xul.dll 	nsEventStateManager::DispatchMouseEvent 	content/events/src/nsEventStateManager.cpp:3445
24 	xul.dll 	nsEventStateManager::NotifyMouseOver 	content/events/src/nsEventStateManager.cpp:3566
25 	xul.dll 	nsEventStateManager::GenerateMouseEnterExit 	content/events/src/nsEventStateManager.cpp:3596
26 	xul.dll 	nsEventStateManager::PreHandleEvent 	content/events/src/nsEventStateManager.cpp:1134
27 	xul.dll 	PresShell::HandleEventInternal 	layout/base/nsPresShell.cpp:6395
28 	xul.dll 	PresShell::HandlePositionedEvent 	layout/base/nsPresShell.cpp:6253
29 	xul.dll 	PresShell::HandleEvent 	layout/base/nsPresShell.cpp:6116
30 	xul.dll 	nsViewManager::HandleEvent 	view/src/nsViewManager.cpp:1074
31 	xul.dll 	nsViewManager::DispatchEvent 	view/src/nsViewManager.cpp:1053
32 	xul.dll 	HandleEvent 	view/src/nsView.cpp:160
33 	xul.dll 	nsWindow::DispatchEvent 	widget/src/windows/nsWindow.cpp:3191
34 	xul.dll 	nsWindow::DispatchWindowEvent 	widget/src/windows/nsWindow.cpp:3214
35 	xul.dll 	nsWindow::DispatchMouseEvent 	widget/src/windows/nsWindow.cpp:3600
36 	xul.dll 	ChildWindow::DispatchMouseEvent 	widget/src/windows/nsWindow.cpp:7554
37 	xul.dll 	nsWindow::ProcessMessage 	widget/src/windows/nsWindow.cpp:4301
38 	xul.dll 	nsWindow::WindowProc 	widget/src/windows/nsWindow.cpp:3925
39 	user32.dll 	InternalCallWinProc 	
40 	user32.dll 	UserCallWinProcCheckWow 	
41 	user32.dll 	DispatchMessageWorker 	
42 	user32.dll 	DispatchMessageW 	
43 	xul.dll 	nsBaseAppShell::OnProcessNextEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:311
44 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:508
45 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:142
46 	xul.dll 	xul.dll@0x96ff23 	
47 	xul.dll 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:216
48 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:199
49 	xul.dll 	xul.dll@0x2e3453 	
50 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:173
51 	nspr4.dll 	nspr4.dll@0x187ff 	
52 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:174
53 	xul.dll 	nsAppShell::Run 	widget/src/windows/nsAppShell.cpp:239

http://crash-stats.mozilla.com/report/index/bp-23480a6c-8834-4760-9340-390f92100414
0  	ntdll.dll  	KiFastSystemCallRet  	
1 	ntdll.dll 	ZwAlpcSendWaitReceivePort 	
2 	rpcrt4.dll 	LRPC_CASSOCIATION::AlpcSendWaitReceivePort 	
3 	rpcrt4.dll 	LRPC_BASE_CCALL::DoSendReceive 	
4 	rpcrt4.dll 	LRPC_BASE_CCALL::SendReceive 	
5 	rpcrt4.dll 	LRPC_CCALL::SendReceive 	
6 	rpcrt4.dll 	I_RpcSendReceive 	
7 	rpcrt4.dll 	NdrSendReceive 	
8 	rpcrt4.dll 	NdrpSendReceive 	
9 	rpcrt4.dll 	NdrClientCall2 	
10 	dhcpcsvc.dll 	RpcCliRequestParams 	
11 	dhcpcsvc.dll 	DhcpRequestParams 	
12 	winhttp.dll 	winhttp.dll@0x146d2 	
13 	winhttp.dll 	winhttp.dll@0x1465c 	
14 	winhttp.dll 	winhttp.dll@0x14591 	
15 	winhttp.dll 	winhttp.dll@0x14567 	
16 	winhttp.dll 	winhttp.dll@0x144cb 	
17 	winhttp.dll 	winhttp.dll@0x14d88 	
18 	winhttp.dll 	winhttp.dll@0x14b96 	
19 	winhttp.dll 	winhttp.dll@0x14cfb 	
20 	winhttp.dll 	winhttp.dll@0xf73c 	
21 	npctrl.dll 	npctrl.dll@0x47ffa 	
22 	npctrl.dll 	npctrl.dll@0x47deb 	
23 	agcore.dll 	agcore.dll@0x3cccfc 	
24 	agcore.dll 	agcore.dll@0x3cd209 	
25 	agcore.dll 	agcore.dll@0x2136f7 	
26 	agcore.dll 	agcore.dll@0x21338a 	
27 	agcore.dll 	agcore.dll@0x213eae 	
28 	agcore.dll 	agcore.dll@0x209a7d 	
29 	agcore.dll 	agcore.dll@0x20a540 	
30 	agcore.dll 	agcore.dll@0x1c28b6 	
31 	agcore.dll 	agcore.dll@0xa93a6 	
32 	agcore.dll 	agcore.dll@0x132250 	
33 	agcore.dll 	agcore.dll@0x83ff3 	
34 	agcore.dll 	agcore.dll@0xb09f7 	
35 	agcore.dll 	agcore.dll@0x15064b 	
36 	agcore.dll 	agcore.dll@0x9f596 	
37 	agcore.dll 	agcore.dll@0x16b41 	
38 	npctrl.dll 	npctrl.dll@0x31520 	
39 	npctrl.dll 	npctrl.dll@0x33c1 	
40 	npctrl.dll 	npctrl.dll@0x27c5 	
41 	npctrl.dll 	npctrl.dll@0x2708 	
42 	user32.dll 	InternalCallWinProc 	
43 	user32.dll 	UserCallWinProcCheckWow 	
44 	user32.dll 	DispatchMessageWorker 	
45 	user32.dll 	DispatchMessageW 	
46 	xul.dll 	base::MessagePumpForUI::ProcessMessageHelper 	ipc/chromium/src/base/message_pump_win.cc:361
47 	xul.dll 	base::MessagePumpForUI::ProcessNextWindowsMessage 	ipc/chromium/src/base/message_pump_win.cc:336
48 	xul.dll 	base::MessagePumpForUI::DoRunLoop 	ipc/chromium/src/base/message_pump_win.cc:205
49 	xul.dll 	base::MessagePumpWin::RunWithDispatcher 	ipc/chromium/src/base/message_pump_win.cc:52
50 	xul.dll 	base::MessagePumpWin::Run 	ipc/chromium/src/base/message_pump_win.h:78
51 	xul.dll 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:216
52 	xul.dll 	MessageLoop::RunHandler 	
53 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:173
54 	xul.dll 	base::Thread::ThreadMain 	ipc/chromium/src/base/thread.cc:165
55 	xul.dll 	`anonymous namespace'::ThreadFunc 	ipc/chromium/src/base/platform_thread_win.cc:26
56 	kernel32.dll 	kernel32.dll@0x51193 	
57 	ntdll.dll 	__RtlUserThreadStart 	
58 	ntdll.dll 	_RtlUserThreadStart 	

In Firefox3.6 and Google Chrome, this works just fine.
Blocks: OOPP
Component: IPC → Plug-ins
QA Contact: ipc → plugins
Martijn, are there STR for this crash?
Just load the url, it should crash after a while (during which Mozilla hangs, basically). I can see this in today's trunk build.
(In reply to comment #2)
> Just load the url, it should crash after a while (during which Mozilla hangs,
> basically). I can see this in today's trunk build.

That parent crash stack has a handle event in it for a mouse double click.. Any chance we got the wrong stack or there was some mouse interaction?
I don't think double clicking has anything to do with this.
Here are some new stacks if you need those:
http://crash-stats.mozilla.com/report/index/55eee879-f3ad-42d1-8ac5-310082100419
http://crash-stats.mozilla.com/report/index/e024dfe9-2bef-4f3e-8a68-55acd2100419

What seems to happen is, is that the Silverlight plugin is stuck for a long time, and then Mozilla apparently decides it has crashed or something.
In Google Chrome you first get a dialog that says that the plugin has stopped working and then asks if you want to wait for it, or just do something else.
Ok, useful to know this is reproducible in more than one browser. Martijn, what version of silverlight are you using? (and if it's 3.0, can you try the new 4.0 that was just released on silverlight.net?)
Still seems to crash using Silverlight 4.
Martijn, does changing the timeout setting (see bug 560932) mitigate?

Benjamin: do you think this should block? Seems pretty bad to me, but not sure how common we think it will be.
Yes, that seems to help.
Whiteboard: [fixed by bug 560932?]
I think we can close this duplicate of that bug. I'm not sure it needs to block in any case: if the plugin takes more than N=10 seconds to respond because the plugin script is actually blocking us, that's an expected and desired behavior, in general.
Google Chrome has a dialog when plugins cause a freeze that takes too long. It would be nice if Mozilla could have something similar.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
blocking1.9.2: ? → ---
blocking2.0: ? → ---
status1.9.2: ? → ---
status2.0: ? → ---
Crash Signature: [@ google_breakpad::ExceptionHandler::WriteMinidumpOnHandlerThread] [@ base::MessagePumpForUI::ProcessMessageHelper]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.