Closed Bug 559578 Opened 10 years ago Closed 10 years ago

No restart notification when selecting a new language on multi-locale builds

Categories

(Firefox for Android Graveyard :: General, defect, critical)

Fennec 1.1
ARM
Maemo
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: aakashd, Assigned: vingtetun)

Details

Attachments

(1 file)

Build Id:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.5pre) Gecko/20100414 Namoroka/3.6.5pre Fennec/1.1b1

Steps to Reproduce:
1. Open the controls window
2. Go to the preferences pane
3. On the language row entry, select a new language.

Actual Results:
No restart notification and string changes are made in some respects. For example, click on "go to page" on the "About Firefox" row entry and it'll show the localized version of that page.

Expected Results:
The restart notification should show and no string changes should be made until after the browser has restarted.
Attached patch PatchSplinter Review
We missed to change the name of the string.
Attachment #439248 - Flags: review?(mark.finkle)
Attachment #439248 - Flags: review?(mark.finkle) → review+
pushed to m-b trunk:
http://hg.mozilla.org/mobile-browser/rev/3c33f3f488a8

pushed to m-b relbranch:
http://hg.mozilla.org/mobile-browser/rev/ce825c90cf36
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Verified fixed, using:
Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2.5pre) Gecko/20100419 Firefox/3.6.5pre Fennec/1.1b1
(this is Fennec1.1b1 build 2)
Status: RESOLVED → VERIFIED
I've changed https://litmus.mozilla.org/show_test.cgi?id=9759 so that it covers testing of that this bug doesn't regress.
It turns out, I can't reference this bug in http://litmus.mozilla.org as regression bug ID, because there is already a regression bug ID set in there, and you can only set one bug ID in there.
I've filed bug 560403 for the wish to have the ability of multiple regression bug IDs.
Flags: in-litmus+
bugspam
Assignee: nobody → 21
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.