Closed Bug 559687 Opened 12 years ago Closed 11 years ago

Load cookies.sqlite lazily

Categories

(Core :: Networking: Cookies, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 572223

People

(Reporter: dwitte, Unassigned)

References

Details

Taras can put some stats here, but he mentioned that eagerly loading cookies.sqlite on startup generates a ton of I/O operations.

To do this we'd need to add a column to the db, baseDomain, and then index on it. Then, when reading in cookies on startup, we load just those required for the pageload. This would happen a few times for the different base domains hit by a given page. Each operation would block, but it'd be faster than loading the whole thing in for sure.

After that, we can either load the whole thing in on a background thread, or keep it lazy. The latter will be hard, I think, if we want to preserve our invariants of max cookie table size and such. We could make them softer limits, perhaps, but that's getting hard.

A related point is removing expired cookies: we do this on startup also, because typically it results in less to read and thus pays for itself. We'd have to change that.
Blocks: 572223
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 572223
You need to log in before you can comment on or make changes to this bug.