If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[SEEN] should not output secret channels

VERIFIED WONTFIX

Status

Webtools
Mozbot
--
enhancement
VERIFIED WONTFIX
8 years ago
8 years ago

People

(Reporter: Svetlana A. Tkachenko, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: 

!seen someone command returns 'someone was last seen at #channel XX time ago' by firebot. it should NOT speak about secret (+s) channels since firebot is present at many public channels and anyone can use this command - thus everyone seeing the output.

Reproducible: Always

Steps to Reproduce:
0) install IRC Client chatzilla, https://addons.mozilla.org/en-US/firefox/addon/16

1) go to irc.mozilla.org

2) Open CZ window, do this:

/attach moznet
/nick settingup
/join newsecretroom
/mode +s
/invite firebot
^ DONT CLOSE THIS WINDOW!

3) join in another tab (chrome://chatzilla/content/) under other nick,

/attach moznet
/nick testrat
/join #bots
hi
/join #newsecretroom
hey(s)
/quit


4) NOW IN FIRST WINDOW in #newsecretroom:
!seen testrat
/kick firebot <-- otherwise you'll leave the room, lose +o, and end up with un-needed channel on this network
/quit
Actual Results:  
!seen testrat returns
testrat was last seen 18 seconds ago, saying 'hey(s)' in #newsecretroom.

Expected Results:  
the bot should output the 'hi' thing from #bots

Additional Information:
I must be able to use !seen in any public channel without getting secret channels famous.
(Reporter)

Comment 1

8 years ago
I started reading the mozbot code
http://mxr.mozilla.org/webtools/source/mozbot/BotModules/Seen.bm
lines 30-33
I see that this seen module can be disabled manually for some channels.

But I don't want secret (+s) channels appear in the bot's !seen output *at all*.
Yhis is what this 'bug' is about.

Comment 2

8 years ago
I disagree.

I'd argue that the behavior should be "if the user asking is in the room where the channel message was seen, list the result"

#developers and #foxymonkies are both secret, but people expect seen to work across them. If I ask !seen biesi while in #developers and the answer is that biesi last spoke in #foxymonkies, as long as I'm in #foxymonkies and could reasonably have been expected to ask there, I should be able to see the answer "biesi last spoke in #foxymonkies 2 minutes ago" or however it goes.

Otherwise, seen becomes useless because 99% of our channels are secret.

Comment 3

8 years ago
Since mozbot doesn't actually track channel modes (and those aren't even consistent across IRC servers) nor who is in each channel, this is a pretty big set of changes requiring a fairly large amount of dev time.  Doable, certainly, and it'd open up a whole realm of possibilities -- it'll just take a fair bit of time.

Also, timeless if you were NOT in #foxymonkies would you expect firebot to say "biesi last spoke in a secret channel 2 minutes ago"?
I'm with timeless.

Also, !seen is incidental to /whois.  If I run /whois on any user that is in #developers, then it will list #developers whether I am in the channel or not (or registered or not); with !seen, the user must have made their most recent remark in a hidden channel for it to be listed by mozbot.

It was through this method that I found #developers...

Comment 5

8 years ago
(In reply to comment #4)
> I'm with timeless.
> 
> Also, !seen is incidental to /whois.  If I run /whois on any user that is in
> #developers, then it will list #developers whether I am in the channel or not
> (or registered or not); with !seen, the user must have made their most recent
> remark in a hidden channel for it to be listed by mozbot.
> 

dont clearly get this idea, you cant learn about a secret channel from someone's whois

> It was through this method that I found #developers...

Comment 6

8 years ago
Mozbot lacks any understanding of channel modes (which would be absolutely required here.) and further, does not keep lists of who's in the channel with it (for timeless' interpretation). So that would be a prerequisite feature set.

It is possible to disable the seen module as a bot admin per-channel, since the module was split off into its own. This would prevent any activity in that channel from ever appearing in the seen database. (This is also up to the bot admin to choose to configure or not.)

If you're expecting the behavior of reporting that the person was active so many minutes ago, in your channel, but nothing else, then that's different. Its not clear to me which behavior you're advocating for here.

Incidentally, I don't think using a "public" IRC bot in a "must be secret" channel is such a good idea. Consider, if firebot had logging enabled and those logs were available on the web, a-la thebot. Then not only would your secret channel be exposed, but not secret at all.

I'm also not convinced that +s/+p secret/private channels really represent such creatures anymore. Aside from hiding them from bots and casual users using !list. If you're really that concerned with people joining your channel, use a channel key.
Severity: normal → enhancement
Depends on: 134609
OS: Windows XP → All
Hardware: x86 → All
(Reporter)

Comment 7

8 years ago
In short. I don't want to see the #foxymonkies channel mentioned anymore. Can you disable the !seen module there and mark this as wontfix. Thanks.

Comment 8

8 years ago
(In reply to comment #7)
> In short. I don't want to see the #foxymonkies channel mentioned anymore. Can
> you disable the !seen module there and mark this as wontfix. Thanks.

No. As I've said previously, I don't want to disable seen in any module firebot is in, as randomly creating holes (that are unexpected to the end-user) in his data. I've refused similar requests from #sumo (where the solution was to instead add a mute so he doesn't duo-respond with sumobot) for the same reason.
From Wolf's last comment, marking as WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 10

8 years ago
SUGGESTION. (WORKAROUND)

Maybe you can make !seen work only when someone /msg es the bot but not in public channels?

Comment 11

8 years ago
Also no.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.